Graphics glitches using internal monitor since kernel 5.10+

I recently bought a Dell XPS 13 9310 with Intel i7-1165G7 CPU and Intel Xe Graphics. It was running perfectly fine before with kernels previous to 5.10.* (I tried 5.6, 5.8, 5.9). However with 5.10.* and 5.11.*, I’m experiencing weird graphics glitches. It mostly shows in the form of short delays while typing or moving the cursor, but can also get more noticeable like objects showing twice while scrolling. In general, it makes the whole system feel unresponsive. It appears both on Wayland and X11 (GDM, Gnome).
I tried setting i915.mitigations=off, but it didn’t change anything. I’m running EndeavourOS with all current updates installed.
The weird thing is that this problem only occurs when I’m on my internal display, any external monitor works. This issue is becoming really frustrating, so maybe someone of you can help to eliminate it :slight_smile:

It is my first post on a Linux forum, so I apologize if there are important pieces of information missing. I’m happy to post logs and more system information.

1 Like

Can you share the output of inxi -Fxxxz

That give us a better idea of your hardware and drivers.

1 Like

Welcome Aboard!
have you tried another kernel? Like linux-zen for example?

Did you try uninstalling the xf86-video -intel?

Wow, thx for the quick responses. I didn’t try linux-zen. Using modesetting driver instead of xf86-video-intel didn’t change anything.
Here is the output of inxi -Fxxxz:

  Kernel: 5.11.15-arch1-2 x86_64 bits: 64 compiler: gcc v: 10.2.0 
  Desktop: GNOME 40.1 tk: GTK 3.24.28 wm: gnome-shell dm: GDM 40.0 
  Distro: EndeavourOS base: Arch Linux 
  Type: Laptop System: Dell product: XPS 13 9310 v: N/A serial: <filter> 
  Chassis: type: 10 serial: <filter> 
  Mobo: Dell model: 0GG9PT v: A00 serial: <filter> UEFI: Dell v: 2.0.0 
  date: 01/28/2021 
  ID-1: BAT0 charge: 37.6 Wh (73.7%) condition: 51.0/51.0 Wh (100.0%) 
  volts: 8.1 min: 7.6 model: LGC-LGC6.5 DELL 2XXFW09 type: Li-poly 
  serial: <filter> status: Discharging 
  Info: Quad Core model: 11th Gen Intel Core i7-1165G7 bits: 64 type: MT MCP 
  arch: Tiger Lake rev: 1 cache: L2: 12 MiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 44864 
  Speed: 1028 MHz min/max: 400/4700 MHz Core speeds (MHz): 1: 1028 2: 1081 
  3: 918 4: 969 5: 728 6: 1101 7: 1054 8: 1056 
  Device-1: Intel Iris Xe Graphics vendor: Dell driver: i915 v: kernel 
  bus-ID: 00:02.0 chip-ID: 8086:9a49 class-ID: 0300 
  Device-2: Microdia Integrated_Webcam_HD type: USB driver: uvcvideo 
  bus-ID: 3-6:3 chip-ID: 0c45:672a class-ID: 0e02 
  Display: wayland server: 1.20.11 compositor: gnome-shell driver: 
  loaded: i915 note: n/a (using device driver) - try sudo/root 
  resolution: <missing: xdpyinfo> 
  Message: Unable to show advanced data. Required tool glxinfo missing. 
  Device-1: Intel Tiger Lake-LP Smart Sound Audio vendor: Dell 
  driver: sof-audio-pci bus-ID: 00:1f.3 chip-ID: 8086:a0c8 class-ID: 0401 
  Sound Server-1: ALSA v: k5.11.15-arch1-2 running: yes 
  Sound Server-2: JACK v: 0.125.0 running: no 
  Sound Server-3: PulseAudio v: 14.2 running: yes 
  Sound Server-4: PipeWire v: 0.3.25 running: no 
  Device-1: Intel Wi-Fi 6 AX201 vendor: Rivet Networks driver: iwlwifi 
  v: kernel port: 3000 bus-ID: 00:14.3 chip-ID: 8086:a0f0 class-ID: 0280 
  IF: wlan0 state: up mac: <filter> 
  Device-1: Intel type: USB driver: btusb v: 0.8 bus-ID: 3-10:4 
  chip-ID: 8087:0026 class-ID: e001 
  Report: This feature requires one of these tools: hciconfig/bt-adapter 
  Local Storage: total: 476.94 GiB used: 27.9 GiB (5.8%) 
  ID-1: /dev/nvme0n1 vendor: Western Digital model: PC SN730 NVMe WDC 512GB 
  size: 476.94 GiB speed: 31.6 Gb/s lanes: 4 rotation: SSD serial: <filter> 
  rev: 11150012 temp: 40.9 C scheme: GPT 
  ID-1: / size: 467.88 GiB used: 27.9 GiB (6.0%) fs: ext4 
  dev: /dev/nvme0n1p2 
  ID-2: /boot/efi size: 511 MiB used: 280 KiB (0.1%) fs: vfat 
  dev: /dev/nvme0n1p1 
  ID-1: swap-1 type: file size: 512 MiB used: 0 KiB (0.0%) priority: -2 
  file: /swapfile 
  System Temperatures: cpu: 38.0 C mobo: N/A 
  Fan Speeds (RPM): cpu: 0 fan-2: 0 
  Processes: 257 Uptime: 43m wakeups: 5438 Memory: 15.35 GiB 
  used: 2.33 GiB (15.2%) Init: systemd v: 248 Compilers: gcc: 10.2.0 
  Packages: pacman: 959 Shell: Bash v: 5.1.4 running-in: gnome-terminal 
  inxi: 3.3.03 

That was a hint that you should try it and then report back. :wink:

Sure, sorry. I’ve installed the zen kernel (was yay -S linux-zen linux-zen-headers the correct way?)

uname -r returned:


Unfortunately, it didn’t improve the situation. It’s almost like the internal display has hick-ups. Is there maybe an easy way to revert back to kernel 5.9.* in EndeavourOS to temporarily solve the issue?

Did you reboot after installing the kernel?

If it is still in your package cache, you can install it from there using pacman -U. Otherwise, you can install the prior LTS kernel, 5.4 from this repo

I did reboot.

1 Like

Have you tried any kernel parameters?


Or possibly


Thx so much @ricklinux, settingi915.enable_psr=0 solved the problem. I can finally enjoy a responsive GNOME 40 desktop. :smile:
Also thanks to everyone else trying to help!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.