Graphical Interface won't start after interrupted pacman update

Classical family issue: I told my wife not to shut down my PC, because it was updating, but…

Of course she had to do it. Now X windows is not starting, but instead the last sentence in boot window is:
“Finished Notify about reboot on special occasions”

Everything else works (I think), but X windows is not starting. Even a new pacman update won’t fix the situation. I guess the last part of pacman session which re-enables the nvidia driver was left out and now something is not in place.

Thanks for helping normal users!

You could try running sudo dracut-rebuild and see if that resolves the situation.

If that doesn’t work, we will need to dig into the logs to see why X is failing.

Thanks! I’ll try try that once I get back home! :slight_smile:

1 Like

Hello, tried that command once, but command not found. I will try tomorrow when I have more time to devote.

Is it an older install?

If so, run sudo mkinitcpio -P instead.

Hi, my pc was facelifted last spring, so for me it is pretty new install.

Anyway, this mkinitcpio did not fix my issue.

I managed to install some dracut modules or programs, but I don\t know where they were installed. Cannot execute any of them…

Or I mean I tried to execute the previous command you gave (dracut-rebuild), but that one was not found.

Ok, I managed to install one more of those many dracut items. Now I was also able to execute ‘dracut-rebuild’. However, nothing changes. I remind that everything else works in my pc, but graphical interface not. I believe that this is related to nvidia in that pacman does something to it and at the end of pacman session, it does something else and exactly that step is missing in my system. So when I run pacman again, it thinks I have no nvidia active and does nothing to it. Or anyway, I cannot get it back by rerunning pacman.

More logs?

Or Xorg logs?

Thanks, I’ll provide them shortly.

Well, maybe not so shortly. I popped at home and tried a few commands for eos-sendlog, but it seems the server is down for DDOS or something.

However, I also checked the nvidia-inst page and based on that the correct driver is installed and the command said all is ok.

Then I briefly checked also Xorg.0.log. There I saw an error about nvidia kernel module not found. That’s probably my issue.

Try reinstalling nvidia related packages. Use
pacman -Ss nvidia
pacman -Qs nvidia
and then
pacman -Syu "those listed packages"

Note that you may need to delete those packages from the cache first, see

(Hope I got the path right…)

Edit: fixed my typo above.

Thanks Manuel, I will try that in the evening.


Hello, here are some logs:


journal -b -0:

jounal -b -2:


I gave you an incorrect command above, but just fixed it there. Sorry about that.
Now the command makes sense… :wink:

Thanks Manuel,
I will try that on Monday.

Have a nice weekend!

1 Like

Good morning! Manuel, your instruction worked like a charm! Thanks a lot!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.