Graphical glitch with Intel iGPU?

Hello, I recently installed EndeavourOS on my laptop with the following specification: i5-12500H, RTX3050Ti Mobile (Aftershock Forge 15s based on Clevo NP50PNK). The system seems to recognize all of these hardware with the iGPU as Intel Alder Lake-P.

I successfully install and boot the Gnome variant. However, once I open the setting app, the UI freezes. The app still responses to my mouse input but there is no visual feedback. Sometimes, the UI even flickers as well. The same goes for Microsoft Edge I installed from AUR where the graphics were only updated when I resize the window. Other apps such as gedit or evince seem to work just fine though.

After having problem with Gnome, I also tried the KDE Plasma variant but to no avail. The setting app refuses to provide any visual feedback. The taskbar and the login screen also freeze. However, they all response to my input, just like Gnome.

I am currently using a dual monitor set up where one monitor being 4K 165Hz (internal screen of my laptop) and the other being 1920p 144Hz. The system fails to recognize 165Hz refresh rate of my laptop screen and there was only 60Hz for me to choose from xrandr (since I couldn’t access the display setting). I have already tried reinstalling xf86-video-intel driver. I am not sure if this is related to the previously mentioned problem but it is worth mentioning.

I am not sure what the cause of the problem is and I suspect that it might be my iGPU. I am still a newbie to the Linux community so these are all the troubleshoots I can do for now. Any help would be really appreciated. Thanks.

Did you try removing the xf86-video-intel driver for the graphical glitches.

Thabk you very much! I removed xf86-video-intel driver and the UI now works. I am still curious why this solves the issue though. Can I still gain the benefit from the iGPU such as GPU acceleration (since the UI does not feel as smooth as I expected but this could be Gnome problem) or playing games?

Anyway, the system still cannot recognize my 165Hz refresh rate but I think this is a separated problem.

It’s best to not use the Intel driver and run on modesetting kernel driver. Yes the other issue is separate. I’m not sure are you running strictly on the Intel for your graphics?

inxi -Ga 

Here is the result of the command you provided:

Graphics:
  Device-1: Intel Alder Lake-P Integrated Graphics vendor: CLEVO/KAPOK
    driver: i915 v: kernel ports: active: HDMI-A-1,eDP-1 empty: DP-1,DP-2,DP-3
    bus-ID: 00:02.0 chip-ID: 8086:46a6 class-ID: 0300
  Device-2: NVIDIA GA107M [GeForce RTX 3050 Ti Mobile] vendor: CLEVO/KAPOK
    driver: nvidia v: 510.60.02 alternate: nouveau,nvidia_drm pcie: gen: 4
    speed: 16 GT/s lanes: 8 link-max: lanes: 16 bus-ID: 01:00.0
    chip-ID: 10de:25a0 class-ID: 0300
  Device-3: Acer BisonCam NB Pro type: USB driver: uvcvideo bus-ID: 3-8:3
    chip-ID: 5986:9102 class-ID: 0e02
  Display: x11 server: X.Org v: 21.1.3 with: Xwayland v: 22.1.1
    compositor: gnome-shell v: 42.0 driver: X: loaded: modesetting,nvidia
    alternate: fbdev,intel,nouveau,nv,vesa gpu: i915 display-ID: :1
    screens: 1
  Screen-1: 0 s-res: 4480x1440 s-dpi: 96 s-size: 1185x381mm (46.65x15.00")
    s-diag: 1245mm (49.01")
  Monitor-1: HDMI-A-1 mapped: HDMI-1 pos: primary,right model: Acer VG252Q
    serial: TH6SG0018521 built: 2020 res: 1920x1080 dpi: 90 gamma: 1.2
    size: 543x302mm (21.38x11.89") diag: 621mm (24.5") ratio: 16:9 modes:
    max: 1920x1080 min: 720x400
  Monitor-2: eDP-1 pos: primary,left model: BOE Display 0x0a2d built: 2021
    res: 2560x1440 hz: 60 dpi: 189 gamma: 1.2 size: 344x194mm (13.54x7.64")
    diag: 395mm (15.5") ratio: 16:9 modes: 2560x1440
  OpenGL: renderer: Mesa Intel Graphics (ADL GT2) v: 4.6 Mesa 22.0.1
    direct render: Yes

Currently running on the Intel. How are you switching graphics to use Nvidia? Is there a way to set it in the UEFI Bios or you need to install optimus manager?

 OpenGL: renderer: Mesa Intel Graphics (ADL GT2) v: 4.6 Mesa 22.0.1
    direct render: Yes

Edit: This another issue besides your monitor issue.

I think you need to get the main laptop monitor working correctly without a secondary monitor hooked up. Then get the second monitor hooked up and displaying properly. Some of these laptops automatically switch to the Integrated graphics output when you hook up a secondary monitor. I don’t know your hardware how it works?

Edit: Check the manual if you have one or UEFI Bios for settings for the nvidia graphics.

I installed optimus-manager just now and tried to switch to Nvidia mode. It seems to work:

OpenGL: renderer: NVIDIA GeForce RTX 3050 Ti Laptop GPU/PCIe/SSE2
    v: 4.6.0 NVIDIA 510.60.02 direct render: Yes
1 Like

What about the monitor issue? Did you also check your UEFI Bios settings for the IGPU settings?

Edit: If optimus manager works then it it won’t matter except the fact that like i say some laptops automatically switch when an external monitor is connected.

I did check the BIOS setting and there seems to be nothing related to iGPU.

1 Like

So now you just try fix the monitor issues.

Alright, thank you very much for your help!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.