Graphical glitch but system is usable, and glitch is gone when killing X

Yesterday I updated my system. Here’s some of my system specification.
The glitch started when I open subnautica game from epic game store that is run using lutris with this settings :
I just open the game for a few seconds because I just tested it to see if it runs well or not. And then the glitch appears. This is how my thunar looks like.
But strangely, my browser seems to be partially fine. But the glitch still remains when I switch focus to other software. I use waterfox-g4-bin from AUR.

After letting it be for a few minutes and no freeze/hang happened, I decided to kill the X using this command

pkill x

After logging in again, the glitch is gone like it never happen.
Is it hardware related problem or software related problem. Any information I need to provide to help the debugging process ?

pacman -Q | grep -i mesa

Above command will result the following. I saw in other post about graphical glitch that someone asks the OP to provide this information:
lib32-mesa 22.2.1-1
lib32-opencl-mesa 22.2.1-1
mesa 22.2.1-1
mesa-utils 8.5.0-2
opencl-mesa 22.2.1-1

Any information / hint about the source of the problem / solution would be really appreciated.
Thank you.

try installing libva-mesa-driver
for hardware decoding on GPU

1 Like

Before installing that, I tested the game again and got the glitch and the monitor became black screen. After I restart, I tried running the game with DXVK off and it runs fine. After installing the suggested package, I was able to run the game with DXVK on. Still not sure if it’s the solution. will continue to play test it for a few days. If no glitches happen, then I can mark this as solution.
Thanks for the suggestion.

1 Like

it is only a bet in the dark from my side… but in cases it is needed i would bet:

1 Like

After I installed that package, I tried to play it again. Got the glitches, but I forgot if I’ve restarted the PC yet after installing the package. After cold restarting the PC, I tried to play the game again. With and without DXVK. so far no glitches yet. I don’t know if it is really the solution, but I will mark it as solution until someone with similar error get the glitches even after installing the package.
Thank you

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.