Graphical bugs with NVIDIA GPU


So I recently switched to Endeavour OS and have gotten a infrequent and annoying graphical bug. It only happens after the computer logs me out. It can happen if I do it manually, but happens more frequently if it happens because the computer goes to sleep mode. About 1/4 of the time according to my, albeit limited, tests.

What happens is that when I get back to my computer I am greeted with a black screen for a while. Then the login prompt shows up, but only with parts of my name. When I log in my wallpaper is gone and some text is also gone, especially the text in the bar at the top of my screen (I use gnome) disappears, that is “activity” the time and the date. The only way I can get it back is if I reboot my system.

These are my system specifications: I also dual boot with windows, and I installed windows first and then Endeavour, if that matters.

I assume I should try to configure the NVIDIA drivers in some way, but I don’t really know where to start. Any help is greatly appreciated.

Gnome uses Wayland by default and recently added nvidia to this default.
Wayland and Nvidia is not the best combination, even if Gnome thinks they are ready.
Try test if the same issue happens with Gnome Xorg session first.
If it does, we can check of other possibilities… :person_shrugging:


I am 99% certain this is a known issue with GNOME+NVIDIA+Wayland resume from suspend (because I see the exact same thing happen).

This is worth trying:

1 Like

I tried that and have let my computer suspend automatically ten times now. The bug hasn’t reappeared so I’m fairly confident that fixed it. Thank you so much!


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.