Graphical Bugs with Flatpaks

Hello there,
since I booted up my system 15 minutes ago, every flatpak has a very strange graphical issue, looking like this:


I tried waiting a few minutes and also rebooted, but that didnt help. So I reinstalled my graphics card drivers (AMD) with xf86-video-amdgpu and reboot. Then this also didnt help and I checked and verified all flatpaks with the command flatpak repair and rebooted. Sadly also that didnt worked for me and I dont know what else I can do. Do you have some other tips and tweaks how I can handle that issue?

PS, Specs:

CPU: Intel Core i5-10400F Six-Core 2.90 GHz
GPU: AMD Radeon RX 6600
RAM: 16 GB DDR4 G.Skill Aegis 3200 MHz
SSD: Kingston NVme 512GB

Thanks in advance!

why would anyone run anything, and especially steam as a flatpak?!?
sudo pacman -S steam and you are done with that. Do yourself a favor and pick vulkan-radeon as vulkan driver during installation if it asks.

For spotify, it is available in the AUR: yay -S spotify


I am also having this issue with a few flatpak apps on an AMD machine with integrated GPU.
It started this afternoon and I can’t see anything among the packages that got updated today directly related to flatpak.



And here is what got updated on this system today:

I haven’t had time to look into this any further.
I just wanted to say that the issue is not only on your end.

PS. I know I could stop using Flatpak apps and that would definitely resolve the issue for obvious reasons :sweat_smile:

okay everyone, as a temporary workaround, you can rollback the org.freedesktop.Platform.GL.default//22.08-extra extension with:

sudo flatpak update --commit=4c6ff4f8c2418f647a814fd14d8c7500d1de7bfd14f10c192eb96a9f638762cf org.freedesktop.Platform.GL.default//22.08-extra

or, if you have org.freedesktop.Platform.GL.default//22.08 installed, with:

sudo flatpak update --commit=bf66cf0adc4293974c628834984b689549fb0906036f6af7bbc62f4d458d516a org.freedesktop.Platform.GL.default//22.08

Source: flatpak matrix room

1 Like

Thanks @GolDNenex for posting!

I thought to do a flatpak update before implementing the workaround to see if there were any new updates released. And there they were!

$ flatpak update 
Looking for updates…
        ID                                           Branch             Op        Remote         Download
 1. [✓] org.freedesktop.Platform.GL.default          22.08              u         flathub        136.5 MB / 135.7 MB
 2. [✓] org.freedesktop.Platform.GL.default          22.08-extra        u         flathub         28.9 MB / 135.7 MB
 3. [✓] org.freedesktop.Platform.Locale              22.08              u         flathub         17.7 kB / 333.2 MB
 4. [✓] org.freedesktop.Platform.ffmpeg-full         22.08              u         flathub          3.8 MB / 4.3 MB
 5. [✓] org.freedesktop.Platform                     22.08              u         flathub         27.5 MB / 214.6 MB

Updates complete.

This has solved the issue on my end.

No need to build it.

I’d rather build it than use Flatpak. :innocent:

1 Like

Work also for me :slightly_smiling_face: Quick fix when you think about the fact that people give they’re time mostly for free.

I’d rather build it than use Flatpak. :innocent:

Flatpak are not that bad tho :stuck_out_tongue:

Yes, that was amazingly a fast fix. I feel so indebted and grateful towards all these people making all these things happening.

1 Like

Steam flatpak has a lot fewer issues with games that use EAC or other anti cheats would be one reason. Flatpak steam worked with Elden Ring a good few days before native for instance and didnt have the issues with glibc that happened later on also. You can also run steam flatpak on LTS distros and get the benefits of using mesa-git without installing it system wide.

You also get the benefit of steam having more restricted system access which is always a good thing


I wouldn’t! :laughing:

well, that leads straight to the next question. Why would anyone play anything using those? xD

yeah, mostly a performance bottle neck is what you get with that.

I do it because the arch steam package had issues every once in a while. The flatpak steam never gave me any issue.

1 Like

They had updates Mesa to 22.3.3 but there were those glitches, so with the newest update they are back on Mesa 22.3.2

Hoping to see a next release with 22.3.4.

Thanks Guys, that helped very much out of my problems!

While I mostly avoid games with them there are a few very much worth playing. You also need to consider that you or I aren’t the center of the actual universe even if we are of our own. Other people do very much want to play games with them.

Can you provide and example? Because while I don’t use steam flatpak at the moment it being a flatpak never effected performance. Valves anti cheat is also known for digging trough user (and your dns cache) files to find cheats.

Valve isn’t your privacy friend, even if they have a slightly better track record

CORRECTION: NOTHING wrong with Flatpaks.

Untrue. Flatpak package names are stupidly long. Also, just use my themes already!


CORRECTION: NOTHING wrong with Flatpaks.

Let’s stop arguing. Also, learn How To Argue - The Hierarchy of Disagreement.