Graphic distortion on MacBook Air 2012 after upgrading to Kernel 6.4.7-arch1-1

Oh, oh. There’s a guide for btrfs filesystems? :no_mouth:

Yeah scroll down on that same guide you linked and it has a section that says other mounting examples.

The process is still the same, but the mounting part changes depending on the file system.

Ok, thank you! i see, I have to mount it otherwise. I’ll try this.

No problem. I’m pretty sure this is what @pebcak was getting at.

1 Like

It’s always located there, I think. :grin:

1 Like

I’m going to bed for tonight. I’ll check back in tomorrow.

Thank you for your help! I was able to arch-chroot my system, now. Good night!

1 Like

Good to hear were you able to downgrade the kernel to the last working version from the chroot?

Alternative to downgrading would be to use LTS Kernel right?

pacman -Syu linux-lts linux-lts-headers

1 Like

Yeah that could work too.

Unfortunately, I am not presented an older kernel. Here’s the result of sudo downgrade linux:

I added the LTS kernel as you mentioned. But starting it up I ended with the same graphic distortion as before. So unfortunately, this is not a solution for my problem.
It seems that I need the 6.3.4 kernel back. Is it perhaps possible to completely re-install my system from USB stick and then upgrade everything except the kernel?
I did the upgrade with sudo eos-update because I had problems with sudo yay. There were some broken keys which prevented the upgrade. I read in this forum to use eos-update in such a case which worked well… except for the distorted video output.

That is strange downgrade is supposed to check pacman cache and the arch linux archive. You can manually download the packages from the arch linux archive and then use pacman to install them. and if you also have the kernel headers installed.

You shouldn’t need to use sudo yay when using yay. Just use yay and it will ask you to activate the parts that need sudo all on its on. As for reinstalling and then updating everything, but the kernel. That may be possible, but I have never tried it from the live iso. Normally to not update a package. You could add the --ignore flag to pacman, but since the installer is doing things for you that won’t work. Perhaps if you edit the /etc/pacman.conf config file. You could add the kernel to the IgnorePkg list. I’m not sure if the installer would take that into account though.

If you choose to download the kernel packages from the archives. Use the command sudo pacman -U [downloaded-package-file] to install it.

If I install an older kernel, does this install an older nouveau driver, too? Installing the LTS kernel should have solved my problem, shouldn’t it? But it did not. Can it be that this problem isn’t related to kernel but to nouveau driver?

Yes, because the nouveau driver is in the kernel, but it is not the only thing you need to make nouveau work. There are userspace utilities that are part of the mesa package that you also need to make it work. Now that you ask though. This entire time we were under the assumption that the kernel was the problem. Did you also update the mesa package around the same time.

Also, I found the legacy proprietary driver for your graphics card I’ve never had to use any of the legacy drivers myself, but usually the proprietary driver works better. I was just trying to get you back in a working state. If you say things broke after a kernel update then, the previous working kernel should still work.

Lastly I’m not sure how the linux lts kernel is built. Perhaps they update the drivers during the lifetime of those kernels as well, so that even the lts kernel has a newer version of some stuff than what you were previously using.

To know for sure, you would need to provide the output of paclog to know what you last updated. Which is provided by the pacutils package which should already be installed.

Another thing I just thought of in order to downgrade the kernel is to use the command ls /var/cache/pacman/pkg/ | grep ^linux and report the output here, so I can see if you still have the previous kernel already in your cache. I probably should have thought of this earlier, my bad. :sweat_smile:

Obviously, the older kernel got removed by eos-update: