"GPGME error: No data"

I have not a clue what’s going on with updates. Last time I tried to update, I think now two days ago, there was an error with one or two packages. I figured “Ah, I’ll deal with this later.” Well, later is now, and now I’m completely thrown off.

   ┌─[2024-06-16   CW24   11:32:47.132110756   UTC+02:00]
└─[$] sudo pacman --verbose --sync --refresh --sysupgrade
   └─[2024-06-16   CW24   11:32:51.890071423   UTC+02:00]

Root      : /
Conf File : /etc/pacman.conf
DB Path   : /var/lib/pacman/
Cache Dirs: /var/cache/pacman/pkg/  
Hook Dirs : /usr/share/libalpm/hooks/  /etc/pacman.d/hooks/  
Lock File : /var/lib/pacman/db.lck
Log File  : /var/log/pacman.log
GPG Dir   : /etc/pacman.d/gnupg/
Targets   : None
:: Synchronising package databases...
 endeavouros                                                                                                      7,5 KiB  17,3 KiB/s 00:00 [--------------------------------------------------------------------------------------] 100%
 core                                                                                                           121,1 KiB   378 KiB/s 00:00 [--------------------------------------------------------------------------------------] 100%
 extra                                                                                                            7,9 MiB  15,0 MiB/s 00:01 [--------------------------------------------------------------------------------------] 100%
 multilib                                                                                                       138,4 KiB   442 KiB/s 00:00 [--------------------------------------------------------------------------------------] 100%
error: GPGME error: No data
error: failed to synchronize all databases (unexpected error)

I could just reinstall the OS, as I generally tend to do when shit like this happens, but right now I’m really not in the mood to do so. I seriously need a new drive to separate my home partition…

I had tried to follow this guide: https://vadosware.io/post/fixing-gpgme-error-on-arch/
but to no avail.

1 Like

Most likely the same issue as in the following topics:

Why would you opt for the “nuclear option” as there may be a simple issue with a simple solution?

Oftentimes, the issues like you are having right now are reported quickly on this forum and most of the times a quick solution to them is found.

1 Like

I had the same problem some time back.

It was resolved by some info i found.

Perhaps this is useful:

Why would you opt for the “nuclear option” as there may be a simple issue with a simple solution?

Because, if nothing else, it is reliable. And I know how to do it, which also helps, especially when I’m in a state of mind that is everything but calm…

Your suggested solution seems to have worked, though, so thank you for that! I don’t understand why it worked, but it did.

1 Like

There has been some issue with that particular mirror lately. Apparently it is not available for EnOS’ repo anymore.

1 Like


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.