Gparted formatted new external as root only; can't fix

Having bought a backup 3tb My Passport, I’d forgotten how dreadful it is now to sort external drives. Running 4 externals already, none of which show in fstab, and they auto-start and can write to them easily … the latest of those I’d had to format as fat32 (luckily it was a 2tb) as I couldn’t work out this root issue.

Drive is formatted as ext4 and mounted. Have looked everywhere and tried everything …

sudo chown -R $wellspring:$wellspring /dev/sde1
sudo chmod -R +w /dev/sde1
sudo chmod -R 777 /dev/sde1
sudo chown -R wellspring:wellspring /dev/sde1

then tried in terminal …
mkfs.ext4 /dev/sde1

Managed to change permissions the following way, but still not able to write …
ls -l /dev/sde1
brw-rw---- 1 root disk 8, 65 Sep 3 02:34 /dev/sde1
sudo chown -fR wellspring:wellspring /dev/sde1
ls -l /dev/sde1
brw-rw---- 1 wellspring wellspring 8, 65 Sep 3 02:34 /dev/sde1

then something I read said to do this …
fsck -l
fsck from util-linux 2.36
e2fsck 1.45.6 (20-Mar-2020)
/dev/nvme0n1p2 is mounted.
e2fsck: Cannot continue, aborting.

Wasn’t best pleased that gparted automatically added msftdata flag either, and it never used to format drives as only root access. Don’t know why ‘b’ shows instead of ‘d’ in permissions, too. Had got away with using fat32 as the solution on the previous drive, as it was a 2tb, but am absolutely stuck with this 3tb one. Would much appreciate advice. :slight_smile:

Quick solution

Try formatting with Gnome Disks (package name gnome-disk-utility )

If you don’t want to re-format

Mount the drive and change permission of the mount point instead of /dev/sde1
sudo chown username /mount/point

Then use a file manager to change write permissions


Awesome @Hystrix :slight_smile: Installed Disks, unmounted, formatted partition as ext4, mounted it again, and it works fine! Deleting gparted was great, lol. :+1:t2:

1 Like

The only feature Disks don’t have is expanding LUKS partitions . Well I don’t really use that . So yes Gparted is useless for me :grimacing:

1 Like

lol, yes :slight_smile: Good that there’s Disks there for what you need, and to save the day generally. :+1:t2:

1 Like

Just in case, you would need to chown the mount point where the partition is mounted and not the partition itself (in this case /dev/sde1). For example if you mount /dev/sde1 at /Data:

sudo chown -R $USER:$USER /Data

Thanks @pebcak :slight_smile: Some places I’d found via search had referenced /Data, but I’d thought they were writing themselves a personal data file on the drive, lol. Good to know. :+1:t2:

It doesn’t have to be /Data in particular. It could be any other mount points. Let say you create a directory called media within which you create a directory called Storage serving as the actual mount point. Then you mount a partition at /media/Storage and change the ownership from root to your user:

sudo chown $USER:$USER /media/Storage


I’m not great with more complex stuff about disks, but that’s great information for if ever I magically get the tech dna strand, lol, or for others. Appreciate it. Thanks.