Gparted does not show UI icons on EOS KDE

Hello friends.

I downloaded Gparted to format with the help of a graphical interface, although I use the terminal for everything else, I prefer to use a graphical interface for this.

Unfortunately Gparted icons are not showing on my EOS KDE.

Is there a way to fix it, or some other better manager than Gparted for EOS?

Maybe I should have asked this question on the KDE subforum?

Thanks in advance.

Maybe your icon theme lacks icon for Gparted?

You could reboot and see if it will show up.

Better … I don’t know but kde has its own partition manager:

Edit: Looks like I misread your post :blush:


If I’m not mistaken, KDE has a GTK section in its appearance settings. Maybe you can try to set the appropriate icon theme there?

1 Like

Which is slower than GParted.

1 Like

The paritioning is slower or the UI’s overall responsiveness?

1 Like

KDE has its own partition manager. for me it runs correctly and fast enough.

2 aur/partitionmanager-git 4.1.0.r1434.d05914c-1 (+134 0.00) 
    A KDE utility that allows you to manage disks, partitions, and file systems. (GIT version)
1 extra/partitionmanager 23.04.3-1 (2.2 MiB 5.4 MiB) [kde-applications kde-system] (Installiert)
    A KDE utility that allows you to manage disks, partitions, and file systems

1 Like

sudo cp -R ~/.config/gtk-3.0 /root/.config/
would solve the issue … as gparted is running as root… it does not make use of users theme settings…


I also have this issue on KDE and haven’t looked for any solution. It’s been this way for a while.

1 Like

I can confirm this worked for me. Thanks!


If the solution from @joekamprad works for you too - don’t forget to mark it as the solution! :grin:


Thanks friend, I downloaded this one and it worked fine and all the buttons were showing!

I tried all the themes and it didn’t work, one of our friend fixed it below, thanks anyway friend!

When I did format (with KDE Partition Manager), it took about 10 seconds on each drive.

Isn’t this very fast, is there a way to do or tell if it’s a fast format or a slow format? (In Windows there are those 2 types of formatting, I don’t know if that also exists in Linux).

Also, is there any difference between Gparted and KDE Partition Manager?

Because I formatted the SSD and HDD with exfat, they both work fine on EOS, but one of them can’t be accessed from Windows 10, because it says you don’t have access, or access is denied (can’t remember).

I figured maybe it’s possible that Gparted and KDE PM format differently or something?

It took me about 10 seconds and everything was formatted correctly, although I would have liked to do a slow format, but I think that only works on Windows 10.

I only had the problem that it only recognizes the SDD and not the HDD since Windows 10 (I don’t know why, both are in exfat).

Thanks friend, it worked!

But I had to format the 2 drives this morning because one of them started crashing on Windows but not on EOS, and I read the first comment and downloaded KDE Partition Manager.

But I fixed the problem thanks to you, thanks again!

PS: I formatted with exfat the SSD and HDD, they work correctly in EOS, but Windows 10 does not have access to the SSD, but to the HDD.

Maybe it’s that KDE Partition Manager didn’t format the drives slow, and did a quick format?

Well, I’m going to open another thread for this, since this topic is solved!

I cleaned up some of the off-topic and/or inappropriate posts from this topic.

Since this is solved I am going to close it.