Google Chrome Prime Nvidia drivers force integrated gpu

Hello, i have a Lenovo Idepad 3 Gaming laptop with the latest version of Endeavour OS with Gnome DE.
I use Prime Nvidia drivers with dual GPU, Nvidia discrete and Amd integrated.
I use the hybrid setting and, as default GPU, i use the integrated GPU but Google Chrome from AUR use the discrete GPU.
How can i make Google Chrome to use the integrated GPU instead of the discrete?
Thanks in advance for the help.

Not sure about chrome but it should be similar. Have a look at the following:

You can read the device/vendor IDs present on the chrome://gpu page and configure it to use a specific GPU with flags:

1 Like

Hello @ainz , thanks for your replay.
This is the chrome://gpu log
about-gpu-2023-12-15T14-11-53-192Z.pdf (328.5 KB)

I tried google-chrome-stable --gpu-testing-vendor-id=0x1002 --gpu-testing-device-id=0x1638 betose it seems to bee the inactive gpu but i read AMD switchable: false and i’m not sure what it mean.
Anyway Google Chrome start on Nvidia GPU.
Can you please help me?

If you only care to use a certain GPU, in this case integrated one without switching, check the options in your system’s BIOS. There should be an option to disable one of the cards. Some laptops only allow disabling of the discrete card, or vice-versa, but it is worth checking if you only plan to use just one of the cards.

1 Like

Hello @ainz.
I use the integrated GPU for all and the discrete for gaming. Everything work but Google chrome, witch I need for work, for my self I use every time Firefox. It is all about battery duration.

Please post output for:

inxi -SMGxx

I’m on wayland

  Host: Prottente Kernel: 6.6.6-arch1-1 arch: x86_64 bits: 64 compiler: gcc
    v: 13.2.1 Desktop: GNOME v: 45.2 tk: GTK v: 3.24.38 wm: gnome-shell dm: GDM
    Distro: EndeavourOS base: Arch Linux
  Type: Laptop System: LENOVO product: 82K2 v: IdeaPad Gaming 3 15ACH6
    serial: <superuser required> Chassis: type: 10 v: IdeaPad Gaming 3 15ACH6
    serial: <superuser required>
  Mobo: LENOVO model: LNVNB161216 v: SDK0T76465 WIN
    serial: <superuser required> UEFI: LENOVO v: H3CN45WW(V3.03)
    date: 09/01/2023
  Device-1: NVIDIA GA106M [GeForce RTX 3060 Mobile / Max-Q] vendor: Lenovo
    driver: nvidia v: 545.29.06 arch: Ampere pcie: speed: 8 GT/s lanes: 8
    bus-ID: 01:00.0 chip-ID: 10de:2520
  Device-2: AMD Cezanne [Radeon Vega Series / Radeon Mobile Series]
    vendor: Lenovo driver: amdgpu v: kernel arch: GCN-5 pcie: speed: 8 GT/s
    lanes: 16 ports: active: eDP-1 empty: HDMI-A-1 bus-ID: 05:00.0
    chip-ID: 1002:1638 temp: 38.0 C
  Device-3: Bison Integrated Camera driver: uvcvideo type: USB rev: 2.0
    speed: 480 Mb/s lanes: 1 bus-ID: 1-3:2 chip-ID: 5986:212b
  Display: wayland server: v: with: Xwayland v: 23.2.3
    compositor: gnome-shell driver: gpu: amdgpu display-ID: 0
  Monitor-1: eDP-1 model: BOE Display 0x0a81 res: 1920x1080 dpi: 142
    diag: 395mm (15.5")
  API: EGL v: 1.5 platforms: device: 0 drv: nvidia device: 1 drv: radeonsi
    device: 3 drv: swrast gbm: drv: kms_swrast surfaceless: drv: nvidia wayland:
    drv: radeonsi x11: drv: radeonsi inactive: device-2
  API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: amd mesa v: 23.2.1-arch1.2
    glx-v: 1.4 direct-render: yes renderer: AMD Radeon Graphics (renoir LLVM
    16.0.6 DRM 3.54 6.6.6-arch1-1) device-ID: 1002:1638 display-ID: :0.0
  API: Vulkan v: 1.3.269 surfaces: xcb,xlib,wayland device: 0
    type: discrete-gpu driver: nvidia device-ID: 10de:2520

API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: amd mesa v: 23.2.1-arch1.2
    glx-v: 1.4 direct-render: yes renderer: AMD Radeon Graphics (renoir LLVM

Have you tried x11 session to see if it works as expected?

I installed Chromium and it work on integrated GPU.
chromium about-gpu-2023-12-16T07-46-39-951Z.pdf (173.2 KB)

On Chromium the gpu0 is actived, on google chrome is the gpu1, but i saw some differences on the used video drivers.

This is Google Chrome

This is Chromium

Same problem on x11, all work on integrated gpu but Google Chrome.

I use [ switcheroo-control

If i try to launch steam with the right click it let me to use the integrated gpu, for steam the default gpu is the discrete, but if i try to do the same with google chrome i have the line to use the discrete, because the default gpu system wide is the integrated, i think it is a problem related only to google chrome.

As the integrated gpu works with chromium, i also think the issue is with chrome. Personally, i don’t use chrome or chromium based browsers. Maybe someone who uses chrome may have some solution to your problem.

Since chromium works, is it possible for you to switch to it instead of using chrome?

I’m not sure, because i need to use my google account connected in google chrome for work, If it were up to me I would use firefox.

Now it is matter of principle, thanks for all the help :smiley:

1 Like

I haven’t been able to make any progress in resolving this issue, any help would be greatly appreciated.
Has anyone else had a similar problem?
Thank you.

This is a vulkan issue on google chrome. Recent chrome versions enabled vulkan by default, but its broken beyond belief.

As we can see from your screenshots on google chrome display type is ANGLE_VULKAN, but on chromium its ANGLE_OPENGL.

Try disabling vulkan: open new tab, go to chrome://flags, find vulkan option, select disabled and restart chrome (don’t click on relaunch, because that does not work most of the time, close the browser and open it again manually).

If that does not work, you can try to force chrome to use GL by starting it like this

/usr/bin/google-chrome-stable --use-gl=desktop

Good point, thanks.
In the next days i’ll do this try!

Thanks a lot @jake99 .
Disabling vulkan on chrome://flags fixed the problem!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.