Going to sleep/rebooting changes primary screen

I have three monitors. I want games to open on the middle screen.

Everything was working fine, until the update of KDE that introduced “screen priorities” instead of having a primary display. Since this update, games never open on my middle screen, but instead on the right screen. This is, until I shuffle the order, and change it back to my desired order.

Xrandr shows the right screen as primary. If I do xrandr --output my_middle_monitor --primary, games also open on the correct screen, so this is definitely the issue.

Setting the computer to sleep, or rebooting it, resets the setting.

Any ideas?

1 Like

Did you change the “active screen” settings?

I don’t see an “active screen” setting. Where is it?

Sorry was trying to remember what it’s called now. It’s inside workspace>window management
you can mess around with the window behaviour options as I know the setting used to live there. Worst comes to worst you can add a window rule under “window rules” that will open everything in the specific monitor that you want.

Something like:
window class: unimportant
window type: Normal Window
and then add the property called “screen” and enter in the corresponding monitor number

Forgive me if I don’t have the details right as it has been a while since I’ve done this. Might need to do a little trial and error on your end.

No, I didn’t change anything there. And I also don’t want everything to open on that monitor, I just want it to set as primary.