Gnucobol not compiling

Not sure if this is the right place but… I’m trying to install gnucobol using yay. I’ve used it before and everything was fine but now when I try to install it I get the following errors:

common.c: In function ‘print_info_detailed’:
common.c:9714:17: error: implicit declaration of function ‘xmlCleanupParser’ [-Wimplicit-function-declaration]
9714 | xmlCleanupParser ();
| ^~~~~~~~~~~~~~~~
make[2]: *** [Makefile:614: common.lo] Error 1
make[2]: Leaving directory ‘/home/dave/.cache/yay/gnucobol/src/gnucobol-3.2/libcob’
make[1]: *** [Makefile:657: all-recursive] Error 1
make[1]: Leaving directory ‘/home/dave/.cache/yay/gnucobol/src/gnucobol-3.2’
make: *** [Makefile:565: all] Error 2
==> ERROR: A failure occurred in build().
→ error making: gnucobol-exit status 4
→ Failed to install the following packages. Manual intervention is required:
gnucobol - exit status 4

Does anyone know how to fix this?

Thanks in advance for any help.

It might be the gcc compiler failing. Try downgrading the gcc compiler.

Please forgive my lack of knowledge but how would I do that?
Much thanks for the quick reply.

Look at this reply. It contains the command.

Thanks again for your help. I’ve tried the command but I’m now having a problem with the package name. When I do a pacman -Q it lists the installed packages but for gcc there is a space in the name. Samething in the AUR. I’ve tried several variations to figure out the real package name but I’m at a loss.

Knowing that I can’t even get the name right on the current package I have no idea on how to find the name of the previous package.

Please forgive me but I’m brand new to EndeavourOS/Arch. I really need specific info on this in order to proceed with your recommendation.

Thanks again for your help.

I had to bail out for a while and choose another distro to get my COBOL back.
Some of the Slackware guys had these same problems and a few others. They were using a different branch of thier sofware called -current rather than their stable version 15. In Slackware -current is much the same as Debian Sid. In -current they were using the 6.9 kernel and gcc 14. They determined that there was a change in one of the parameters for the 6.9 kernel. A change in a parameter was setting mitigations to y where it was always set to n in the past. They changed the parameter with CONFIG_MITIGATION_GDS_FORCE back to n. They recompiled the kernel and everything worked so they sent out an updated kernel.
I can’t remember which kernel I was on here but it’s something to be aware of.

It appears that, for me here, I need to downgrade gcc gcc-libs and possibly gcc-fortran to get working. From what I’ve read this is how to get there:
Install downgrade from the AUR – yay -S downgrade.
Once installed you can type sudo downgrade gcc and it will provide a list from which you can pick which version you want to revert to.
The items can be blacklisted if you want in /etc/packman.conf by entering – IgnorePkg = gcc.
More than one item can be placed in that line, separated by a space.

If I’m wrong on any of this please let me know. I’m anxious to do a reinstall of EndeavorOS to see if this all works.