Gnome Tweaks


I have a small issue that I’m sure is actually a package issue. When I install gnome-tweaks, and open it after, it only displays the “General” screen, but there are no sections to the left such as “Appearance” “Mouse and Touchpad” etc.

Has this been experienced before and where do you think I can start troubleshooting it?

I’ve found something here for Debian based systems ( … tomisation):

Maximize your Tweaks window. If you don’t see left panel then try to sudo apt purge gnome-tweaks && sudo apt clean && sudo apt update && sudo apt install gnome-tweaks

During removing it shows no dependencies, so it seems, the package itself could contain issues or maybe installed not properly or became corrupted during OS using.

But I’m a little confused as to how to replicate the same commands on Pacman :frowning:

That’s just telling you to remove it , clean any apt cache , update apt and then install again

I guess you could sudo pacman -R gnome-tweaks , sudo pacman -Sc , sudo pacman -Syu , sudo pacman -S gnome-tweaks

you could read here

and see if pacman -Sc is too hardcore for you , an alternative is listed

if you have installed EndeavourOS GNOME it should be installed already per default…
so if you have installed GNOME after initial installation, how did you do that?

and may starting tweaks from terminal show some errors:


I was hopeful of that way, however unfortunately it’s still not working :frowning:
Thank you though.

[Edit: To also answer your question, I installed EndeavourOS Gnome from the ISO as per normal, the only change I made was trying to add ceti-2-theme from pamac, which has worked in some scenarios and not in others.
I am also experiencing this via another distro - Arcolinux, which makes me think it’s a bug in the package with the latest update.]

You’re right, it was on the default settings, however even then it didn’t open correctly, so I uninstalled it, reinstalled it and still the same.

I’ve attached some pictures to show you what I’m seeing.
This is when I ran it in Terminal, unfortunately, no errors or anything.

ha ha the screen is to small, so it decides to hide the left part… :man_teacher:
good that you show a screenshot here…


So it’s down to the resolution and it’s cut out part of the application? I presume when I use a higher resolution it will appear back then.

I’ll test it.

Well I do try and give as much info as I can, sometimes words aren’t enough. As they have said before, a picture is worth a thousand words.

you see also left top corner is not rounded


you could try make the window bigger also, but there is not much space left left and right of it


Works a treat! I increased the resolution of the VM keeping the 4:3 ratio and it worked. tweaks

Learn something new everyday!

Thank you so much!!


this is also a new thing from latest GNOME update i think

I kinda like it, means it’s responsive to the screensize, but it would be useful to have a warning on the general page saying “Warning: Screen size too small to show full application” or something of that sort. :slight_smile:

usually, it shows an indicator for this:
but your Desktop size was even too small to show this one whjat is indicated by the not rounded corner:

1 Like

Well thank you for spotting that, it’s much appreciated. I’ll be sure to check this now when running VMs. :slight_smile: