Gnome-Terminal Not Working

Hello, mates.

Today I observed that the option Open in Terminal is not working anymore and crashing the window. So I googled and someone somewhere taught how to fix it by opening the Gnome-Terminal directly and by unchecking the “Run custom command instead of my shell” option. But my Gnome-terminal does not open either.


Someone knows something about, please?

First, make sure your system is fully up-to-date and reboot.

If that doesn’t help, install a different terminal and try running gnome-terminal from that terminal. Hopefully there will be some kind of error message displayed in the terminal.

1 Like

Hello, @dalto


I am really upset. To shorten the story:

  1. Open terminal here decided not work today;
  2. gnome-terminal decided not work anyway;
  3. I uninstalled gnome-terminal;
  4. I created a symlink with sudo ln -s /usr/bin/gnome-tilix /usr/bin/gnome-terminal to use tilix rather than gnome-terminal but it did not work either. And, to make everything worse, open in terminal simply disappeared.
  5. I tried to reinstalled gnome-terminal but the output is:

error: failed to commit transaction (conflicting files)
gnome-terminal: /usr/bin/gnome-terminal exists in filesystem
Errors occurred, no packages were upgraded.

that is, the fckng package is already installed, but when I run the command pacman -Ss gnome-terminal the output is:

oskaralhos@archlinux [09:24:17 PM] [~]
→ % pacman -Ss gnome-terminal
extra/gnome-terminal 3.40.1-1 (gnome)
The GNOME Terminal Emulator

that is, it seems to be not installed.

In resume, I’m upset and don’t know what to do.

This is your problem. When the package tries to install it can’t install the binary because your symlink is in the way.

Delete the symlink and then install gnome-terminal

Ok, @dalto


I deleted the symlink as you told me and installed the gnome-terminal successfully, thanx to you, bro, but gnome-terminal still insists in not work.


However, the nautilus executed only now some changes that I tried to do before but it did not do.

It brought back the Open in Terminal but also installed the Open Tilix Here and the nautilus-terminal. At least, the nautilus-terminal (gnome-terminal) works and Tilix too. And the system is fully updated.


What do you suggest, mate?

Does gnome-terminal work at all? What happens when you run gnome-terminal from tilix?

Nope, mate.


The output:

You need to edit your locale-gen (/etc/locale-gen) to suit your locale, uncomment the locale that matches your language and then from tilix run locale-gen again and then Gnome-Terminal should work.

5 Likes

Hello, @anon61101858
Thank you for your help.


This problem used to occur in Manjaro cuz after the first system update the locale was simply disconfigured. And we had to reconfigure it to fix the terminals. But in EndeavourOS this does not use to happen. My locale.conf was generated by EndeavourOS and had two languages, en_US.UTF-8 for the system language and pt_PT.UTF-8 for time, date, money and for some other portuguese stuff. And, first of all, I have been using it for months, so, why does that problem come up now?


But I decided to follow your hint and edit the locale.conf and I wiped away the pt_PT.UTF-8 from the file, regenerated the locale-gen and reupdated the grub and rebooted the computer and voilà, the gnome-terminal came back. Problem solved!


Thanks, @anon61101858

2 Likes

Excellent! I had exactly the same issue after a fresh Arch install yesterday morning.

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.