Gnome sound settings not seeing my subwoofer

So as the tittle sugests I am having problems with my sound. I switch between 5.1 and stereo quite frequently based on what I am doing. Today I tried to for the first time and noticed on the gnome settings that my subwoofer was not found. The rest of the speakers show up and work. I have checked my connections, I have restarted, I have killed pulse audio and restarted it. Nothing. What should I try next? I am not finding anything anywhere.

So I have been working with ringo on telegram. This is what we have got. I don’t know how long it has been like this because I rarely use 5.1 only when gaming at my desk which I rarely do. It has probably been several weeks at least so who knows if it is because of an update or not. I have tried booting the fallback kernel same deal. I have played with all the settings and made sure nothing but the mic was muted in both pulse audio and alsamixer. In pulse I can raise the volume of it, but, I don’t think that makes a difference. In Gnome settings sound page I have my analog line out selected, set to 5.1, and in test it shows a question mark over the subwoofer. When you click it static comes out of the center speaker, but, I am pretty sure that is normal behavior. The volume slider for the sub on the sound page is dark and doesn’t move.

I have tried alsactl restore with and with out sudo. Here are what came back.


I’m not really sure what else to try. Any suggestions welcome.

1 Like

Dear woodrowsmith,

First let me apologize for this delayed response; I had a physician’s appointment and could not respond until I got back home.

I think that you should go into (as root) etc/pulse/daemon.conf.

On my media computer I have modified the daemon.conf text file to the following:

# This file is part of PulseAudio.
# PulseAudio is free software; you can redistribute it and/or modify
# it under the terms of the GNU Lesser General Public License as published by
# the Free Software Foundation; either version 2 of the License, or
# (at your option) any later version.
# PulseAudio is distributed in the hope that it will be useful, but
# WITHOUT ANY WARRANTY; without even the implied warranty of
# General Public License for more details.
# You should have received a copy of the GNU Lesser General Public License
# along with PulseAudio; if not, see

## Configuration file for the PulseAudio daemon. See pulse-daemon.conf(5) for#
# more information. Default values are commented out. Use either ; or # for
## commenting.

; daemonize = no
; fail = yes
; allow-module-loading = yes
; allow-exit = yes
; use-pid-file = yes
; system-instance = no
; local-server-type = user
; enable-shm = yes
; enable-memfd = yes
; shm-size-bytes = 0 # setting this 0 will use the system-default, usually 64 MiB
; lock-memory = no
; cpu-limit = no

; high-priority = yes
; nice-level = -11

; realtime-scheduling = yes
; realtime-priority = 5

; exit-idle-time = 20
; scache-idle-time = 20

; dl-search-path = (depends on architecture)

; load-default-script-file = yes
; default-script-file = /etc/pulse/

; log-target = auto
; log-level = notice
; log-meta = no
; log-time = no
; log-backtrace = 0

; resample-method = speex-float-1
; avoid-resampling = false
; enable-remixing = yes
; remixing-use-all-sink-channels = yes
; enable-lfe-remixing = no
; lfe-crossover-freq = 0

flat-volumes = no
; flat-volumes = yes

; rlimit-fsize = -1
; rlimit-data = -1
; rlimit-stack = -1
; rlimit-core = -1
; rlimit-as = -1
; rlimit-rss = -1
; rlimit-nproc = -1
; rlimit-nofile = 256
; rlimit-memlock = -1
; rlimit-locks = -1
; rlimit-sigpending = -1
; rlimit-msgqueue = -1
; rlimit-nice = 31
; rlimit-rtprio = 9
; rlimit-rttime = 200000

; default-sample-format = s32le
; default-sample-rate = 44100
; alternate-sample-rate = 48000
; alternate-sample-rate = 88200
; alternate-sample-rate = 96000
; alternate-sample-rate = 132300
; alternate-sample-rate = 144000
; alternate-sample-rate = 176400
; alternate-sample-rate = 192000
; alternate-sample-rate = 352800
; alternate-sample-rate = 384000
; default-sample-channels = 8
; default-channel-map = front-left,front-left-of-center,front-center,front-right,front-right-of-center,lfe,rear-left,rear-right

; default-fragments = 4
; default-fragment-size-msec = 25

; enable-deferred-volume = yes
; deferred-volume-safety-margin-usec = 8000
; deferred-volume-extra-delay-usec = 0

First: I am using a media center computer (running Manjaro but the same recommendations will apply to EndeavourOS) which connects to an AV receiver via HDMI.

Second: You will notice that I have not modified the

; enable-lfe-remixing = no
; lfe-crossover-freq = 0

sections; I leave the crossover points to the receiver and the subwoofer itself. (I have the crossover on the receiver set to 80 Hz and the High Cut on the subwoofer set to 120 Hz. Within my system, this affords a very smooth transition.)

Third: the major change I have made is with the default-sample-format and the default-sample-rate.

If you would like to be able to play high definition audio, I recommend that you change the settings on your computer to the ones I have. Do not just copy & paste them; I have found that that doesn’t work. You have to manually type the changes to the file and then, of course, save it. (If you do not wish to play such files, you can leave those sections alone.)

You will have to change the default-sample-channels to the number of channels you have (if you have two channels plus a subwoofer, then your setting would be 3; for multi-channel it would be the number of speakers you have).

You would then change the default-channel-map to the settings I show for the various channels. Again, do not copy & paste; you must manually type the channels into the file.

Then, of course, you would “save” everything in the file. Close everything out (and exit from root) and try playing some music.

I think that changing these settings within PulseAudio (the folder in /etc is labeled Pulse) will fix your problem and allow your subwoofer to be recognized.

I sincerely hope that this post has been of some use to you and I would appreciate it if you would tell me if it works (or if it doesn’t).

Best of luck!


P.S. I forgot to mention the following: if you do not connect your computer to your amplifier via HDMI, you will need a DAC which can handle multi-channel. You would then connect your computer to the DAC via USB and then connect the DAC to the audio inputs of your amplifier.

I spent a few hours on this yesterday. I will get back on it and compare our configes at a later time and report back. I am playing the two expansions of the first halflife before i start Black Mesa over now that Xen has been released. I don’t need more than stereo right no. I have a 5.1 logitech analog speaker set. My motherboard has a nice DAC built in and the built in soumdcard is 7.1 for analog. I don’t use HDMI. It is an up to date gaming system. The speakers have worked fine for several years. If I don’t get this fixed do to a few other reasonsI will make a fresh install. This was originally antergos until i converted it.Plus I rebuilt the PC switching from intel to amd and only kept the drives and didn’t fresh install. It may just be time. It works, but, there are some quirks. Worst case scenario? I have wasted my time and the ancient speakers have retired. They are several years old.

1 Like

So I’ll see what happens. Since I am 5.1 and not 7.1 I changed it to remove the side speakers. I have a 7.1 set of headphones, but, I only ever use the speakers or streaming to the TV with steamlink. It is a gaming PC that I use primarily for a HTPC. I only have surround in the office for gaming. I’m not sure the steamlink would let me set of surround in the living room. If it can I may go blutooth to the TV and set that up through the steamlink if it works. I will try with these settings and the improved sample rates. Thanks for that by the way. I’ll report back.

1 Like

Well After the changes I also had to turn up master woofer in alsamixer. I put iamamiwhoami’s kin which is a 5.1 album on guayadeque and the woofer works. in test it still shows a question mark but plays static through the center speaker like it is supposed to. I am thankful for the sample rate changes as my library is mostly flac, but, the issue seems to be alsa related. I had already fixed it and not realized until I tested listening to something in 5.1. Good tip.

1 Like

Dear woodrowwsmith,

I’m glad that it’s now working for you. I use the QasMixer program and, looking at hw : Card, I have Master, PCM, and Line Out all set to maximum. You can use any alsa adjustment program to make the change(s) if necessary.

I should note that I am using the Xfce desktop edition on my computers; my laptops are all running EndeavourOS but my Media Center Computer (the one whose settings I quoted) runs Manjaro. (I have them all set to “look” exactly the same.) However, at least regarding sound output, Manjaro or EndeavourOS makes no difference whatsoever.

I have no experience with the Gnome DE, not having used it in over eight years.

To get rid of your question mark problem, why not try adjusting, in the daemon.conf file the

; enable-lfe-remixing = no
; lfe-crossover-freq = 0

Change the values to 1) yes and 2) 80 (a reasonable crossover frequency but you could use whatever frequency you desire) and see if that gets rid of the question mark.

Of course, if everything (the sound output) is working properly otherwise, who cares if there is a question mark or not?

Logitech speakers are really good, especially considering their small size; I have a pair of them (stereo only) from over ten years ago and they still work perfectly, though, frankly, I only rarely use them today.


Same here. I only use surround when I game, and, I rarely game. Then it is usually over the steamlink to the TV and steam controller. I use it for Kodi mostly and a few odd games. BUT. For the two months until Half Life Alyx is released every game in the series is free to download and play, and I lost the hard copies of the classic games anyway. So I am going to bug out on Half Life and some of them have surround, then play Black Mesa the remake of the first game and re-imagining of the final chapter of it, using the second games Source engine has finally been released as a full game. I will be ready for half life puzzles again when the time comes.

As to the speakers, this is the best 5.1 system for PC’s they made back then. It is also well over ten years old. They still preform admirably.

I think for now the question mark can stay. It isn’t hurting anybody. I plan to fresh install for other reasons soon anyway. I will definitely keep the altered conf file though.

1 Like