Gnome Shell using nearly all RAM

I’ve been having very frequent glitching and DE lag as I mentioned in this post. I marked it solved but it was only temporary unfortunately.

The hangups have gotten far worse and while it’s happening, I see in Usage that Gnome Shell is using 9.0-10.2GB of RAM and the CPU is often at 100%.

Disabling all Gnome extensions had no immediate effect on RAM or CPU use.

Is it safe to guess that something in the latest Gnome releases are not playing well with my hardware, or is there something else I could look into?

inxi -FAZ --no-host | eos-sendlog

1 Like

Depends on what you mean by disabling all gnome extensions had no immediate effect on ram or cpu use. Did you reboot after doing this or did you simply disable them and expected the resources to be freed? If your answer is the latter, then keep all extensions disabled and try to use vanilla gnome for a while and see if your problem comes back.

1 Like

I failed to reboot while disabling them. :tired_face:

Switching to vanilla Gnome, rebooting and seeing how it goes. I’ll share the findings after a day or so.

1 Like

Cool. Good luck.

notebook with optimus gpu hardware?
and unhandled. Output shows it is running on igpu

Were you using GSConnect extension? That extension has (or atleast I faced, and issue is documented too) memory leak issue where overtime gnome-shell memory usage becomes more. If yes, that might be the culprit.

I was not using that one, but no doubt some extension I was using caused the trouble. I’ll add them back one by one until I find it!

Oh dangit! I’m not sure what to do about that but I’m thankful you pointed it out. I’ll have to look into how to remedy that. Any suggested posts or links I should check?
Edit: Since I’m using Intel-Nvidia, I’m going to to install and use Optimus Manager instead of the Nvidia Settings I now have. (How to get amd-nvidia hybrid laptop to work with proprietary drivers? - #9 by ricklinux)

This has hardly anything to do with superfluous RAM usage.
iGPU (i7 CPU) should be more than enough to run (even) Gnome.

Agreed, but as a side note iGPU is not what I want as primary anyway.

that’s totally true indeed… even software rendering would not cause RAM usage rising that much…
top/htop/glances or even Gnome system Monitor could give a hint on what is causing most load/RAM usage

@joekamprad Perhps I’m moving off topic here, if so I can create a new thread.

After following the steps in EOS Wiki for Optimus Switch and optimus-switch-gdm, I now have the switch in my toolbar and it’s showing Switch to Intel iGPU.

However, a new inxi -FAZ --no-host | eos-sendlog still suggests that Intel iGPU is running.

If following the EOS Wiki step by step hasn’t worked, perhaps I have a conflict somewhere. How can I determine that and make Nvidia default?

(And should this be in a new thread?) :grin:

better use a new thread indeed…
to set nvidia running all the time you do not need optimus-manager

1 Like

As for my Gnome Shell consuming all available RAM, switching off all extensions worked. I’m slowly adding them back one at a time to find the culprit.