Gnome shell extension pop-shell in Gnome 44

Has anyone tried installing the Gnome Pop-shell extension in Endeavour’s Gnome 44 environment? Is it compatible?

I don’t normally use pop shell extension on my GNOME systems and I am not on my Arch box at the moment to test but on a Fedora one.

In Fedora you could install this extension from the official repos and it seems to be working fine.

$ gnome-shell --version
GNOME Shell 44.3
$ dnf info gnome-shell-extension-pop-shell
Last metadata expiration check: 2:37:12 ago on Thu 17 Aug 2023 06:21:11 PM CEST.
Installed Packages
Name         : gnome-shell-extension-pop-shell
Version      : 1.2.0^11.b5accce
Release      : 1.fc38
Architecture : noarch
Size         : 421 k
Source       : gnome-shell-extension-pop-shell-1.2.0^11.b5accce-1.fc38.src.rpm
Repository   : @System
From repo    : updates
Summary      : GNOME Shell extension for advanced tiling window management
URL          :
License      : GPL-3.0-only
Description  : Pop Shell is a keyboard-driven layer for GNOME Shell which allows for quick and
             : sensible navigation and management of windows.  The core feature of Pop Shell
             : is the addition of advanced tiling window management - a feature that has been
             : highly-sought within our community.  For many - ourselves included - i3wm has
             : become the leading competitor to the GNOME desktop.

Thanks a lot for your reply! :slight_smile:
I’m using Gnome Endeavour OS and I’m afraid of installing Gnome Pop Shell extension and have some incompatibility.

gnome-shell-extension-pop-shell’ metadata.json:

“name”: “Pop Shell”,
“description”: “Pop Shell”,
“version”: 2,
“uuid”: “”,
“settings-schema”: “”,
“shell-version”: [

You could see the shell versions supported.

The instructions on how to install it in Arch is in the link I posted above.
It’s up to you of course if you want to give it a try.

Yes. It works fine here on fedora. It’s been a couple months but it was still working on Endeavour the last time I tried it.

I did have to go into dconf and I had to disable the extension verification check to get it going though.


Not really an answer to your question but there are other tiling extensions that are great and still up to date with latest Gnome version (Pop Shell is not).
Forge and Tiling Assistant for example.