Gnome-shell core dump


My machine won’t display the GDM screen. When it boots both Wayland and then X11 fail with the same core dump:

May 05 18:47:27 myhost systemd-coredump[855]: [🡕] Process 806 (gnome-shell) of user 120 dumped core.
                                                            Stack trace of thread 806:
                                                            #0  0x00007831d0ed1660 getenv ( + 0x16d1660)
                                                            #1  0x00007831d0f0d0e3 n/a ( + 0x170d0e3)
                                                            #2  0x00007831d0f0caa5 n/a ( + 0x170caa5)
                                                            #3  0x00007831d2f75297 n/a ( + 0x5297)
                                                            #4  0x00007831d2f7538d n/a ( + 0x538d)
                                                            #5  0x00007831d2f8c580 n/a ( + 0x1c580)
                                                            ELF object binary architecture: AMD x86-64
May 05 18:47:27 myhost gnome-session-binary[733]: Unrecoverable failure in required component org.gnome.Shell.desktop

I never get the greeter to login to the GUI, so I can only login via ssh or through a text tty.

Note that auto-login is disabled.

~# grep Automatic /etc/gdm/custom.conf 

Anyone else come across this? What can I do to investigate and fix this?

Extra info:

root@myhost ~# coredumpctl info
           PID: 1002 (gnome-shell)
           UID: 120 (gdm)
           GID: 120 (gdm)
        Signal: 11 (SEGV)
     Timestamp: Sun 2024-05-05 20:40:08 BST (3min 28s ago)
  Command Line: /usr/bin/gnome-shell
    Executable: /usr/bin/gnome-shell
 Control Group: /user.slice/user-120.slice/session-3.scope
          Unit: session-3.scope
         Slice: user-120.slice
       Session: 3
     Owner UID: 120 (gdm)
       Boot ID: 0e1b69a39edd4f8dac3d2f52dd8335b9
    Machine ID: dd71e9df01ee4b7d9fa0cd8c2980dd76
      Hostname: myhost
       Storage: /var/lib/systemd/coredump/core.gnome-shell.120.0e1b69a39edd4f8dac3d2f52dd8335b9.1002.1714938008000000.zst (present)
  Size on Disk: 808.8K
       Message: Process 1002 (gnome-shell) of user 120 dumped core.
                Stack trace of thread 1002:
                #0  0x00007f54e92d1660 getenv ( + 0x16d1660)
                #1  0x00007f54e930d0e3 n/a ( + 0x170d0e3)
                #2  0x00007f54e930caa5 n/a ( + 0x170caa5)
                #3  0x00007f54eb2fb297 n/a ( + 0x5297)
                #4  0x00007f54eb2fb38d n/a ( + 0x538d)
                #5  0x00007f54eb312580 n/a ( + 0x1c580)
                ELF object binary architecture: AMD x86-64

you should post the journal, check here for a how to

UInfortunately that seems to require a UI…

$ journalctl -k -b -0 | eos-sendlog

(yad:3089): Gtk-WARNING **: 19:22:37.859: cannot open display: 
Nothing sent.

EDIT: I was wrong, there’s an option for this:

$ journalctl -k -b -0 | eos-sendlog --no-yad

Jiournal at:

Also note that I do see a graphical screen message, so it seems this is gdm not able to start…

Wow! Seems like the file may have been bad?

I reisntalled the package of the library mentioned in the core dump and it fixed it!

$ yay -Qo /usr/lib/ 
/usr/lib/ is owned by js115 115.10.0-1

$ yay -Sy js115

$ systemctl restart gdm
# now it works!
1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.