Gnome screen flickering on zoom

Hey folks! I put this question in the pub because its not an eos problem.

But I have to use zoom at work, as much as it pains me, I guess a lot of people are in the same boat.

I still have problems with screen sharing, the image flickers when sharing on gnome. Anyone using screen sharing on zoom? Which DE worked best, did you have to disable any effects and such? Any workarounds appreciated.

Fyi , used xorg, under wayland the screen-sharing on zoom is disabled entirely.

Using plasma, I haven’t had any issues or at least nobody has mentioned any.

Are you seeing flickering when you are viewing a shared screen or are others seeing it when you share your screen?

Other see my screen flickering, my screen is good from my side. this morning was caught by suprise while giving a demo on linux and open source tools, just had zoom on my laptop for a couple of weeks and forgot to check screen sharing, a little embarrassed.

On plasma I had to disable effects to not get the flickering while sharing. I installed via AUR. Are you using flatpak?

I use both Arch and Fedora. On Arch I use the AUR package and on Fedora, the flatpak.

Nice!

1 Like

I might suggest trying the flatpak, wouldnt hurt anything

Ive had stuff that refused to work for me from properly for me from AUR that shouldve but flatpak or appimage versions worked flawlessly :man_shrugging:

I.E Flowblade before it was in the repos if i installed from AUR would have garbled audio on export but the flatpak no issues.

1 Like

So its just?

sudo pacman -S flatpak

Is flatpak stable on arch? I used it ubuntu but never on arch.

yeah flatpak is just fine,

you wanna run

sudo pacman -Syu flatpak

1 Like

Running it under wayland?

no hes running it under x11 as apparently wayland it flat out doesnt work

1 Like

Yep, its a pity, as I had a great experience with multi monitor and wayland/gnome. But zoom doesn’t support it so I logged out and back into x11 session. I will try flatpak tomorrow and see how it goes, its already a step forward.

@Zircon34 did you find a solution by any chance?
I’m experiencing the same issue and it’s so frustrating. Anything related to screen sharing has flickering, making it impossible to use (Zoom, Google Meet, etc).
I’ve tried the intel driver fix with “AccelMethod” and it removed flickering but slew down the computer significantly, so I had to revert it.
Any help would be appreciated.

Here’s my setup:

Graphics:
  Device-1: Intel TigerLake-H GT1 [UHD Graphics] driver: i915 v: kernel
  Device-2: NVIDIA GA107M [GeForce RTX 3050 Ti Mobile] driver: nvidia
    v: 510.54
  Device-3: Microdia Integrated_Webcam_HD type: USB driver: uvcvideo
  Display: x11 server: X.Org 1.21.1.3 driver: loaded: intel resolution:
    1: 1920x1200~60Hz 2: 1920x1080~60Hz
  OpenGL: renderer: Mesa Intel UHD Graphics (TGL GT1) v: 4.6 Mesa 21.3.6

Hi Marek, welcome to the forum!

In the meantime I switched over to xfce and i3wm, and no screen flickering on zoom sharing. Cinnamon seems to work too but I have to switch off certain windows effects.

I also had flickering on kde. I suspect it’s related to windows effects but haven’t found a solution yet. Big bummer.

Am using zoom extensively right now. Running Plasma only.
Zoom client is hit+miss, in that most of the time it will simply dump after attempting to start from the zoom link. Reinstalls don’t help. Browser link works well, so I removed zoom client completely.
When on X11 I can screen share. Wayland cannot.
Both X11 and Wayland flicker slightly if I am also getting a notification come through on Signal Desktop client. Otherwise they are ok.

[onyx@onyx-pc ~]$ inxi -G
Graphics:
  Device-1: Intel CoffeeLake-H GT2 [UHD Graphics 630] driver: i915 v: kernel
  Device-2: NVIDIA TU117M [GeForce GTX 1650 Mobile / Max-Q] driver: nvidia
    v: 510.54
  Device-3: Logitech Webcam C170 type: USB driver: snd-usb-audio,uvcvideo
  Display: wayland server: X.Org 1.21.1.4 driver:
    loaded: modesetting,nvidia resolution: 1920x1080~60Hz
  OpenGL: renderer: Mesa Intel UHD Graphics 630 (CFL GT2)
    v: 4.6 Mesa 21.3.6

Hi @Zircon34, thanks for your quick reply! I had really hoped there would be a solution to this issue. To be honest, I’ve invested a lot of time in customizing my Gnome setup, so it’s not easy to switch but I guess there’s no other way.

Hi @onyxnz, so you’re saying it works for you on KDE, even with Wayland? I’m not sure I understand what other zoom app you use if not the zoom client?

Yeh, I have removed the Zoom client completely, as it was totally unreliable. When clicking a zoom link it will give me a browser screen shown like this:


Click Ok, click Join from your browser, everything works happily.
Browser= Vivaldi.
Kde Plasma on Wayland.

That’s so weird. I don’t see the “Join from your browser” link at all.
Maybe I need to remove the Zoom client first in order for it to appear (?)

For me the browser option never worked to share my screen… The zoom app works well for me, but unfortunately not on kde. I will try again at some point in the near future. Xfce/i3wm it is for now.