Gnome Remote Desktop issues in EndeavourOS

I just installed EndeavourOS and when I go to desktop sharing this is what happens, which is not a great first time user experience as you can’t even close the window:

Now, an old thread here mentioned installing gnome-remote-desktop via pacman, so I did and that made the settings (and the close button) appear.

However, now I instead get “Authentication failed: The connection transport layer failed.” when I try to use Connections from another machine to access this one.

firewall-cmd --permanent --add-service=vnc-server
firewall-cmd --reload
and then check Settings/System/Remote Desktop

Thank you for the tip!

I’m confused about one thing, though… I’ve heard that VNC used to be a fallback and is now completely deprecated, so why isn’t the permanent entry named something like gnome-remote-desktop or rdp-server?

Searching for firewall and gnome-remote-desktop yields surprisingly little results… some say it’s enough to open just the 3389 ports in both tcp and udp.

There’s no GUI app for the firewall, for people used to such things?

EDIT: A bit of internet searching tells me that running the command “ss -ntlp” shows me that something called “gnome-remote-de” is listening to port 3389 but when I try that firewall-cmd command above, it throws errors saying there’s neither a “gnome-remote-de” service or a “gnome-remote-desktop” service…

So, the previous reply’s terminal commands did not alter the error message, and neither did the following commands:

[eobet@leplup Sandy]$ sudo firewall-cmd --zone=public --add-port=3389/tcp --permanent
[sudo] password for eobet: 
[eobet@leplup Sandy]$ sudo firewall-cmd --zone=public --add-port=3389/udp --permanent
[eobet@leplup Sandy]$ firewall-cmd --reload

I’m now in the exact same place of problem that I had with OpenSuse Aeon, Fedora Silverblue and Garuda Linux. Perhaps I should just install Nobara on my media server too because I’ve confirmed that RDP works there out of the box…

@eobet ,
I’ve found thinlinc for you and took my first baby steps in it.

sudo pacman -Sy openssh
systemctl start sshd
yay -S thinlinc

It’s a browser based application. A wizard starts at the end of the installation.
It does the firewall setings as well. Suspiciously helpfull. Port 1010 for administration and
https://<server IP>:300
asks for user and password and – accepting the risk behind Advanced button at first run –
you are in

ThinLinc is free for up to 10 concurrent users per organization

I have found that NoMachine is a better option when it comes to remote sessions and Wayland, they also support Linux.

Thank you for both recommendations! They seem to go beyond the local network, though so I’m a bit wary about that.

But, I’m very happy to report that Gnome Remote Desktop is finally working for me in EndeavourOS!

The solution was that I discovered that there actually was a GUI app for the firewall which came with the OS, and while it didn’t seem to respect the display scaling, didn’t wait for me to type my password using the OSD keyboard, didn’t save any changes I made, I did see that there was a “rdp” service name that I could enable via the command line, and I think that finally did the trick!

Now, I must still unfortunately connect via IP, and not the machine name, so that’s probably also a service I need to add which I don’t know the name of… anyone happen to know it?

Add your nodes to /etc/hosts

Thank you for the tip!

I’m curious, though… how did my two Windows machines previously manage to find each other by hostname without me editing their hosts files?

“There are more things in Heaven and Earth, Horatio, than are dreamt of in your philosophy.”

1 Like

Seems my Orbi mesh thingy I bought years ago never got dnsmasq support so now I’m considering this:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.