Gnome not starting on latest kernel


I have an issue with Gnome when using the latest 5.10.11-arch1-1 kernel: when starting the computer, Gnome does not appear to load. It gets stuck at a black screen with a white blinking cursor. To solve it, I switch the virtual console by pressing ctrl+alt+f2 and then go back to the 1st one with ctrl+alt+f1 and Gnome suddenly starts.

I’m quite sure it’s a kernel issue as this does not happen with LTS (although with that one I run with some Lutris issues).

Any clue or tip on how to fix it? Here are my system specs:

5.10.12 is in Arch testing, so either use LTS for now, or if you want to see if 5.10.12 will work then either cherry-pick it from testing or or use another kernel at 5.10.12 (e.g. linux-lqx).

(Also, it’s generally a good thing to post text output as text.)

1 Like

Sorry for posting as image, instead of text. Won’t happen again.

In the meantime I’ve found a failed systemd backlight service and masked it, and it solved the issue at least for now. I’ll look into your suggestion too.


The failed systemd backlight probably can be fixed with a kernel parameter acpi_backlight=video in the grub command line.

1 Like

After Googling a bit, looks like it’s a systemd issue and it can be fixed by adding the following line to gdm.service:

ExecStartPre=/bin/sleep 1

To modify the mentioned service need to do

$ systemctl edit gdm.service

Hopefully someone finds this helpful :slight_smile:


This here worked, thanks. :smile: I rebooted a couple of times to verify and it worked both times.

1 Like

This helped me:

1 Like

Welcome to the forum. Thanks for giving EndeavourOS a try. Good to see it being used on a production machine? (Senior Software Developer working on EndeavourOS)

I hope you enjoy your time here.


Hey, thanks for the welcome :slight_smile: Yes, I actually use EndeavourOS on my production machine doing a lot of coding and devops stuff. I’ve been doing distro-hopping a lot recently loving Arch Linux the most because it keeps me very productive. After having Manjaro for some time I noticed I’m more the vanilla-kinda-guy, so I gave EOS a try. And I think I may have found my final destination, so I signed up here :wink: