Gnome losing display configuration on log out/reboot

Hi all, I hope someone can help with with this as it’s driving me nuts.

My setup: laptop linked to two external displays, the larger of which is configured as my main display while the third display and laptop are on either side. I have the main display set at 100% scaling with the others set to 125% (fractional scaling enabled).

I’ve been running this setup for over a year and for some reason this problem started only very recently: every time I log off or reboot my computer, Gnome resets the display settings back to default, which messes up the layout of my displays and also disables fractional scaling. It’s like the user display config gets wiped every time.

I have no idea what caused this behavior to start happening, so I’m stumped as to how to solve it.

Any advice or pointers at where to start looking would be most welcome.

This is apparently a known issue with gnome.

A good number of users managed to resolve the issue by turning off the HiDPI daemon. Maybe you can try this first.

Thanks for the suggestion, but I don’t have HiDPI enabled to begin with.

The issue I’m having is affecting more than the scaling - the relative positions of my multimonitor setup gets completely reset every time, plus the primary display gets reset to my laptop display

I see. This user reported the same thing:

Bad news is that it was reported back in 2019. Looks like it still hasn’t been solved.

Did you try this:

Check pacman logs to look for recent updates. Did you update nvidia drivers recently? Does this issue still occur with the LTS kernel?

Yeah, I think it’s a slightly different issue that the solutions posted in that Github thread.

I tried sudo cp ~/.config/monitors.xml ~/.config/gdm but all that did was copy the screen resolution to the GDM login screen and my problem persists once I reach the desktop.

One interesting thing I have noticed, though, is that the problem fixes itself if I do the following:

  1. Reboot
  2. Login to desktop (desired settings have been reset)
  3. Re-enable fractional scaling by running gsettings set org.gnome.mutter experimental-features "['scale-monitor-framebuffer']" in a terminal
  4. Log out of the current session to GDM
  5. Log back in (desired settings have been restored!)

So re-enabling fractional scaling effectively restores all the monitors positions/rotation without me having to manually put them back where I want them. I’m not sure what that means, but at least it’s something.

Check pacman logs to look for recent updates. Did you update nvidia drivers recently? Does this issue still occur with the LTS kernel?

My laptop has an AMD APU, so no Nvidia drivers to worry about. I’ll try out the LTS kernel and see if that does anything to help.

That did it! I have no idea why, but switching to the LTS kernel fixes the problem.

Thanks, mate - you’re a legend!

1 Like

Hmm. So it’s a kernel issue. You should probably report this somewhere.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.