Gnome Extensions app not opening after Mesa update

I am using Gnome on X11 but after the update of Mesa Gnome-Extensions-app does not open…I tried to open it through Terminal and this comes, “/usr/bin/gnome-extensions-app: line 2: 30540 Segmentation fault (core dumped) /usr/bin/gjs /usr/share/gnome-shell/org.gnome.Extensions “$@””… I went to Wayland and gnome-extensions-app works just fine…I found a workaround in reddit though…which is that I have to enter “GSK_RENDERER=Cairo gnome-extensions-app” in terminal then only gnome-extensions-app opens in X11…Can anyone please help?

It appears that you have found the problem and a workaround - what do you need help with?


Welcome to the community!

I am not very familiar with the issue at hand but it may get fixed in time with future updates. In the meantime, you can implement the workaround into the desktop launcher so it launches normally.

  1. cp /usr/share/applications/org.gnome.Extensions.desktop ~/.local/share/applications/.
  2. Edit the file ~/.local/share/applications/org.gnome.Extensions.desktop
  3. Find the line that starts with Exec= and modify it so it is GSK_RENDERER=Cairo gnome-extensions-app as you described above.

This will allow you to use the gnome extensions application normally with the workaround in place.

1 Like

Actually I just wanna know if this will get fixed but upcoming update or not and most importantly I wanted to make this bug appear in front of the Devs as maybe they won’t even know if this is not highlighted maybe many users don’t use X11 so they won’t notice it as of now…however as of now I’m just using this workaround…Thank you pal !

1 Like

On the contrary most user do use x11 of course unless they use Gnome. :wink:

1 Like

One can assume that bugs will be fixed by updates, but without checking whether this has been reported upstream there’s no way of knowing whether it will be fixed in the “next” update.

You’d need to report it to the GNOME developers.

I run GNOME under Xorg and gnome-extensions-app runs fine for me, so it’s not a problem for all users. It might even be specific to your system - for example, you might be in a partial upgrade, or missing some dependency, or you’ve made a configuration change for another reason that has changed the default renderer.

1 Like

It looks like you’re not the only one having this problem:

It would be interesting to know how the systems compare.

1 Like