Gnome - dolphin cant search files

Hello all

I have installed the dolphin file manager, because I do not like the gnome standart. Unfortunately the search does not work and I do not understand why, surely I am missing some dependency.

Hello, you know that dolphin comes from KDE. Maybe there is a conflict between KDE and Gnome!
But I’m sure, that someone can help you, because here working very good people. :grinning:

Yes I know that, but I don’t know a good alternative for it.

IIRC, it’s baloo that’s the default indexer and search “engine”.

What does pacman -Qq | grep -i baloo show you?

You should have all the baloo bits. Maybe you need to enable the baloo service with something like balooctl enable and balooctl start. See for more.

Be aware that the first indexing may take some time and CPU usage depending on what files you have present.

pacman -Qq | grep -i baloo

i have activated balooctl and now it does something, i will wait for the result

balooctl enable
Enabling and starting the File Indexer
[tealk@tealk-tuxedo-aura15 ~]$ mdb.c:2130: Assertion 'rc == 0' failed in mdb_page_dirty()
KCrash: Attempting to start /usr/lib/baloo_file
KCrash: crashing... crashRecursionCounter = 2
KCrash: Application Name = baloo_file path = /usr/lib pid = 33661
KCrash: Arguments: /usr/lib/baloo_file 
mdb.c:2130: Assertion 'rc == 0' failed in mdb_page_dirty()

Tank you

You’re welcome but keep in mind, that even on pure KDE Plasma systems, a lot of people disable baloo …

You could look at an alternative such as Recoll.

Edit: just saw you’re having problems. Sorry, but I can’t help with that.

Instead of Nautilus I use Nemo on Gnome. It’s GTK-based and doesn’t pull a lot of dependencies. Search works both by file name and content on my end.

And as a bonus, it has “open as root” function as well :wink:

but nemo doesn’t have such a nice sidebar or two column view?

It has a side bar. Perhaps it’s not nice :blush:

View: Extra pane (Fn3)?

1 Like

if it would be possible to insert own categories that would be great

too bad I can not hide the desktop in the sidebar

You could bookmark any folder to see it in the left pane/bar.

Even the Sun has got spots!


yes but all are listed under “my computer”

On my end, the get listed under “Bookmarks” in the left pane/bar.

Have you looked at Thunar?

But it doesn’t come with search function. I added catfish but it doesn’t search in the file manager window itself, it pops up a separate window.

Any tips/tricks?

Yes, somehow I was able to show this only via the menu item bookmarks

unfortunately has no two column view

That is also a big bummer for me with other file managers.

1 Like

nemo I like so far even quite good, had not expected that so many functions have been added since it is a fork of Nautilus

can you teach nemo to use tilix as a console?

I don’t understand this now, when I want to change to the root via sftp I get the message:

This should work (at least the same method worked for me quite a while back when I still used Xfce/Thunar)

1 Like

Thanks but this is what I was wondering.

The next time you open Thunar, you should see the option to Search for files when you click on File in Thunar's menu bar.

So basically it still doesn’t have an integrated search and pops up a separate search.

1 Like

No and yes! :wink:

1 Like