Gnome Desktop icons missing in Atlantis neo

In the latest release icons for e.g. Chrome, github-desktop, Telegram etc. are missing in the Taskbar for me.

What icons? If you mean appindicators, you will need to get an extension for those from https://extensions.gnome.org

When you say the icons are missing, can you be a little more specific?

For example, do you mean the applications aren’t installed or do you mean the “tray” icons aren’t showing?

I refer to the icons of installed software docked in main default taskbar at the bottom of the screen. I noticed that problem maybe 10 years ago in the very first Gnome/Arch implementation. Now after installation of other packages from aur, the icons have suddenly appeared: problem solved!

you need to add apps to your favorites to have them in the taskbar.

So I did. I guess, the problem could be reproced. As said, they have appeared now all of a sudden and fine for me. However, newbies may be surprised in the first moment.

but surprised about what exactly? The bar shows only one icon as we do not set up favorites per default, user needs to add them as they like.

1 Like

OK. I need to install EndeavourOS every 2-3 months on different hardware. I have never had this issue other than yesterday with neo; but it is not that important.

I’ve been using GNOME a lot recently, I’ll give it a look again later today, but I don’t recall having these issues. - I see Telegram - what were the other programs in question? I’ll give it a look.

1 Like

As said, the install only puts Nautilus/Files in the favourites dock.

1 Like

After a while (no idea what causes it), they do appear.

Hi there. I don’t know exactly why, however after installing the gnome-extra package all icons were shown correctly.

2 Likes

that`s a group of all extra packages for gnome you can think of:
https://archlinux.org/groups/x86_64/gnome-extra/

so default GNOME apps will show up on the dock because… you install them, the default EndeavourOS GNOME package lists are the minimum set of packages without any extras.
User can decide what exactly is needed in the workflow…

But this thread is already solved and for new issues … new thread please :wink:
And a welcome here at the forum for you @rrr :milky_way: :enos_flag: :vulcan_salute:

closing