Gnome desktop gets stuck in Activities overview

Is anyone else finding that their Gnome desktop is getting stuck in the “Activites” overview screen. I am unable to click on any of the windows shown when this happens. I have no idea what triggers this to happen, but it seems to happen in both X11 & Wayland desktop sessions. Sometimes it even happens when I haven’t moved my mouse to the corner of the screen to bring up the “Activities” overview. The only way out is to log out and back in again.

I’m running gnome-shell version 1:3.38.4-1.

My inxi -Fxza output is:

System:    Kernel: 5.11.10-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 10.2.1 
           parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=f4a38316-ac59-4e5c-a8b1-8eaf4671e28f rw 
           rootflags=subvol=@ quiet loglevel=3 nowatchdog mitigations=off 
           Desktop: GNOME 3.38.4 tk: GTK 3.24.28 wm: gnome-shell dm: GDM Distro: EndeavourOS base: Arch Linux 
Machine:   Type: Desktop System: Intel Client Systems product: NUC8i7HVK v: J71485-504 serial: <filter> 
           Chassis: Intel Corporation type: 3 v: 2.0 serial: N/A 
           Mobo: Intel model: NUC8i7HVB v: J68196-504 serial: <filter> UEFI: Intel v: HNKBLi70.86A.0064.2020.1028.1438 
           date: 10/28/2020 
Battery:   Device-1: apple_mfi_fastcharge model: N/A serial: N/A charge: N/A status: N/A 
           Device-2: hidpp_battery_0 model: Logitech MX Keys Wireless Keyboard serial: <filter> 
           charge: 55% (should be ignored) rechargeable: yes status: Discharging 
CPU:       Info: Quad Core model: Intel Core i7-8809G bits: 64 type: MT MCP arch: Kaby Lake family: 6 model-id: 9E (158) 
           stepping: 9 microcode: DE L2 cache: 8 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 49599 
           Speed: 1197 MHz min/max: 800/8300 MHz Core speeds (MHz): 1: 1197 2: 2255 3: 1226 4: 1282 5: 1420 6: 1840 7: 912 
           8: 900 
           Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
           Type: l1tf mitigation: PTE Inversion; VMX: vulnerable 
           Type: mds status: Vulnerable; SMT vulnerable 
           Type: meltdown status: Vulnerable 
           Type: spec_store_bypass status: Vulnerable 
           Type: spectre_v1 status: Vulnerable: __user pointer sanitization and usercopy barriers only; no swapgs barriers 
           Type: spectre_v2 status: Vulnerable, IBPB: disabled, STIBP: disabled 
           Type: srbds status: Vulnerable 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Intel HD Graphics 630 driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:591b class ID: 0380 
           Device-2: Advanced Micro Devices [AMD/ATI] Polaris 22 XT [Radeon RX Vega M GH] vendor: Intel driver: amdgpu 
           v: kernel bus ID: 01:00.0 chip ID: 1002:694c class ID: 0300 
           Display: server: X.Org 1.20.10 compositor: gnome-shell driver: loaded: amdgpu,ati,intel 
           unloaded: fbdev,modesetting,vesa display ID: :0 screens: 1 
           Screen-1: 0 s-res: 3840x1080 s-dpi: 96 s-size: 1016x285mm (40.0x11.2") s-diag: 1055mm (41.5") 
           Monitor-1: DisplayPort-2 res: 1920x1080 hz: 60 dpi: 93 size: 527x296mm (20.7x11.7") diag: 604mm (23.8") 
           Monitor-2: DisplayPort-3 res: 1920x1080 hz: 60 dpi: 93 size: 527x296mm (20.7x11.7") diag: 604mm (23.8") 
           OpenGL: renderer: AMD VEGAM (DRM 3.40.0 5.11.10-zen1-1-zen LLVM 11.1.0) v: 4.6 Mesa 21.0.1 direct render: Yes 
Audio:     Device-1: Intel CM238 HD Audio driver: snd_hda_intel v: kernel bus ID: 00:1f.3 chip ID: 8086:a171 class ID: 0403 
           Device-2: Advanced Micro Devices [AMD/ATI] Polaris 22 HDMI Audio vendor: Intel driver: snd_hda_intel v: kernel 
           bus ID: 01:00.1 chip ID: 1002:ab08 class ID: 0403 
           Device-3: Logitech Logitech StreamCam type: USB driver: hid-generic,snd-usb-audio,usbhid,uvcvideo bus ID: 6-1:2 
           chip ID: 046d:0893 class ID: 0300 serial: <filter> 
           Sound Server: ALSA v: k5.11.10-zen1-1-zen 
Network:   Device-1: Intel Ethernet I219-LM driver: e1000e v: kernel port: f040 bus ID: 00:1f.6 chip ID: 8086:15b7 
           class ID: 0200 
           IF: eno1 state: up speed: 100 Mbps duplex: full mac: <filter> 
           Device-2: Intel I210 Gigabit Network driver: igb v: kernel port: b000 bus ID: 05:00.0 chip ID: 8086:157b 
           class ID: 0200 
           IF: enp5s0 state: down mac: <filter> 
           Device-3: Intel Wireless 8265 / 8275 driver: iwlwifi v: kernel port: b000 bus ID: 06:00.0 chip ID: 8086:24fd 
           class ID: 0280 
           IF: wlan0 state: down mac: <filter> 
           IF-ID-1: eth0 state: down mac: <filter> 
Bluetooth: Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8 bus ID: 1-9:3 chip ID: 8087:0a2b 
           class ID: e001 
           Message: Required tool hciconfig not installed. Check --recommends 
Drives:    Local Storage: total: 1.86 TiB used: 590.35 GiB (30.9%) 
           ID-1: /dev/nvme0n1 maj-min: 259:2 vendor: Samsung model: SSD 970 PRO 1TB size: 953.87 GiB block size: 
           physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 rotation: SSD serial: <filter> rev: 1B2QEXP7 temp: 49.9 C 
           scheme: GPT 
           SMART: yes health: PASSED on: 185d 20h cycles: 740 read-units: 10,878,547 [5.56 TB] 
           written-units: 11,562,304 [5.91 TB] 
           ID-2: /dev/nvme1n1 maj-min: 259:0 vendor: A-Data model: SX8200PNP size: 953.87 GiB block size: physical: 512 B 
           logical: 512 B speed: 31.6 Gb/s lanes: 4 rotation: SSD serial: <filter> rev: SS0411B temp: 39.9 C scheme: GPT 
           SMART: yes health: PASSED on: 364d 17h cycles: 12 read-units: 5,643,534 [2.88 TB] 
           written-units: 2,054,343 [1.05 TB] 
Partition: ID-1: / raw size: 953.37 GiB size: 953.37 GiB (100.00%) used: 192.32 GiB (20.2%) fs: btrfs block size: 4096 B 
           dev: /dev/nvme0n1p2 maj-min: 259:4 
           ID-2: /boot/efi raw size: 512 MiB size: 511 MiB (99.80%) used: 560 KiB (0.1%) fs: vfat block size: 512 B 
           dev: /dev/nvme0n1p1 maj-min: 259:3 
           ID-3: /home raw size: 953.37 GiB size: 953.37 GiB (100.00%) used: 192.32 GiB (20.2%) fs: btrfs block size: 4096 B 
           dev: /dev/nvme0n1p2 maj-min: 259:4 
Swap:      Kernel: swappiness: 60 (default) cache pressure: 100 (default) 
           ID-1: swap-1 type: file size: 29.8 GiB used: 0 KiB (0.0%) priority: -2 file: /swap/swapfile 
Sensors:   System Temperatures: cpu: 64.0 C mobo: 29.8 C gpu: amdgpu temp: 53.0 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 293 Uptime: 3h 45m wakeups: 23 Memory: 31.27 GiB used: 2.83 GiB (9.0%) Init: systemd v: 247 Compilers: 
           gcc: 10.2.0 alt: 9 clang: 11.1.0 Packages: pacman: 1570 lib: 468 Shell: Zsh (sudo) v: 5.8 default: Bash v: 5.1.4 
           running in: gnome-terminal inxi: 3.3.01

Extensions-wise, I’m running:

  • Dash to Dock
  • OpenWeather
  • KStatusNotifierItem/AppIndicator Support
  • Removable Drive Menu
  • User Themes

I had this happen to me, but figured it was because I was messing with Gnome 40. It was sort of random, but turning extensions off completely seemed to stabilize things for me. Today I decided I was going to keep messing with Gnome 40, so I removed all of the extensions I had previously installed assuming that not all of them will be updated for Gnome 40/Gtk4. A surprising number of the extensions have already been updated for 40, so I reinstalled a bunch and now seem to be stable again.

Honsetly, I am not sure if removing and reinstalling extensions fixed anything or if that was just a coincidence?

PS - There isn’t a Gnome 40 version of Dash to Dock (yet?) … that’s one of the two extensions I use that I am still waiting on (the other is caffeine)

1 Like

I’ve disabled everything except for:

  • OpenWeather
  • KStatusNotifierItem/AppIndicator Support
  • User Themes

Will see if that helps. I have a hunch that Dash to Dock is the culprit.

1 Like

You might be right. D2D is one of my favorite extensions, but it’s caused me issues more than once in the past.

No issues since my last post, so I’m guessing it was Dash to Dock. I’m going to use this as a sign that I should try to use a more vanilla Gnome setup.

I have same issues and assume it was coming from BottomPanel. My most important extensions meanwhile work:
Just like you, I will also take this as sign to reduce my number of extensions.

Omg I was stuck in the middle of a zoom meeting, I could talk but not get out of activity overview. It happened a couple of times that day and wiped gnome. Only had dash to dock and a tiling extension installed. Now we know.

Gnome is not for me :cry:


I had that problem initially when I had updated to Gnome 40 using [gnome-unstable] repos to upgrade from a prior version. The lock-up in a gray overview screen issue was annoying but I was able to pinpoint a few problem candidates. I went through the Extension app and removed all of my extensions, then reinstalled only those that are providing a Gnome 40 compatible version. I found that even with G40 compatible extensions, enabling “Window List” and/or “windowNavigator” causes this erratic behavior - as long as I keep those two extensions disabled I don’t have any issues. I use quite a few extensions as you can see below and currently haven’t run into any issues in weeks of daily use:
Screenshot from 2021-04-18 08-17-40

1 Like

Dash to dock/panel always make problem after update, so i stay away . Pop shell straight off git work great . I really enjoy Gnome + Pop Shell on arm :crossed_fingers: smooth +zero problem so far on Gnome 40


I hear that. I always try it. But no matter how many times I try, and even generally like it. Extensions completely ruin the experience for me every time. I always end up running back to KDE/Cinnamon/XFCE+i3.


When I initially started having these problems I was using Gnome 3.38. I doubt the transition to Gnome 40 solved anything.

This was kind of what killed Gnome for me. Why fight the DE when you can use a DE where you don’t have to.

I’m really a proponent of people using whatever DE they find most to their liking. For me, I continue to use Gnome and I actually like the changes that 40 brought to the table.

What I don’t understand is why people feel the need to hate on Gnome or throw shade if it’s not the right thing for them? I can find plenty of other threads where people have problems with other DEs too, but I am not on those threads telling everybody how that killed “DE X” for me?

I guess I don’t see what any one gains out of posts like that? Are people looking for a gold star just for being contrary? Or does everyone thing they are performing some kind of public service by putting down Gnome?


I know this is not intended for me (or think so). But my post above was not meant to start a DE war or digress from OP. I also had gnome partially upgraded to 40, when the problem happened with activities. The solution to the problem may be to temporarily deactivate the dash to dock extension.

Perhaps it may be good to close this post since the issue is solved?

Edit: I think the look of gnome is super polished, but such freeze problems make it difficult to use at work; I have the same with KDE. Mostly issues with nvidia. I started using i3wm on a daily basis, and am trying xfce now.

@Zircon34 Zircon34 - Yeah, my post wasn’t aimed at anyone in particular, and I’m not looking to start arguments. I’ll get over it. :slight_smile:

Carry on everyone, back to your regularly scheduled programming…

I was a huge Dash to Dock user and really missed it. I have been using the ‘Bottom triggers Activities overview’ extension which has filled that hole in my workflow. It’s pretty close to having Dash to Dock with the dock at the bottom of the screen and set to autohide.

There are a few folks working on a Gnome40 version of Dash to Dock, but I think it’s going to be a while before it’s ready.

1 Like

I see nothing wrong with stating that X killed DE Y for me. Objectively speaking, I opened this thread to find out what was causing the problem I was having with Gnome. After finding out what it was, The solution I found was to switch DE. Throughout this process, I realised that I was fighting Gnome more than I was loving it. Hence, my comments.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.