Gnome defaulting to X11 on boot

Hello, I tried to search some solutions to this but I haven’t found anything that has worked so far, so I figured I’d ask here!
So every time I start up my computer, gnome defaults (using gdm) to the x11 windowing system. It was always using Wayland before, not sure what happened. But if I log out then back in without changing anything, it selects Wayland like it should do when it first boots up.
If anyone has any solutions for me, that would be great. It’s not the end of the world, I would just like the smoothness of Wayland to be default, and not have to log out and in to get it that way.
Thanks in advance,

gear wheel bottom right on login screen . set it there

The only options I have when I logout are :
Gnome (already selected)
Gnome Classic
Gnome on Xorg
But the issue is that once I reboot or shutdown and startup again, it always defaults to X11, even though I have never selected it.
Like I said, I can logout and login (without selecting anything) and it automatically goes to what it should have already been, Wayland. It’s just a weird issue and I don’t want to have to log in and out everytime I reboot.

Have a look at this and this.

I had to add


to my /etc/mkinitcpio.conf since I am on Intel graphics which enables early KMS. After regenerating initramfs and reboot the three options (‘GNOME’, ‘GNOME classic’ and ‘GNOME on Xorg’) are there in GDM, and GNOME session is on Wayland.


Awesome, that was perfect for me! The only thing I did was look on here:
Which after you told me that, told me exactly what I needed to do for my setup (amdgpu), the same thing just using that instead!
Thank you very much for the help! It works exactly like it did before now, thank you! :slight_smile:

1 Like