Gnome dead

hello party people
ive used gnome for eternity on my notebook now and a couple days ago it started lagging really bad and barely functioning
and i mean you can count the seconds per frame
i got lucky enough to be able to take a screenshot of htop but have no idea what to do with it honestly
i switched to kde for the time being but would love nothing more than going back
ive tried to switch back once a day or so uninstalling kde and slapping gnome back on but always got the same result
wayland/xorg/classic all weilded the same results

any help would be appreciated
i do have a handful of extensions installed

Disable all the extensions, log out and log back in and see if it helps.
If it does, re-enable them one at the time until you catch the culprit.

Create a new user account.
Log out and log into the new account. Is it any better?

would you know a command to disable/remove all extensions? none of the ones i have are vital and i cant get into settings or anything, id be lucky to end up in a terminal

Depends how you have installed them.

If you have installed them for the current user, they are all under /home/“username”/.local/share/gnome-shell/extensions.

If you want to remove them, you can delete all of them. Log out and log back in.

If you want to disable them, I guess the following should work:

gsettings set disable-user-extensions true

If you have used pacman (and/or yay) to install them systemwide, then assuming you know the “package neme”: sudo pacman -R "package name"

1 Like

Depends how you installed, but if from the web “store”:

mv ~/.local/share/gnome-shell/extensions/ ~/.local/share/gnome-shell/extensions-old/

Should do it.

deleted all extensions but the issue is still pretty much the same
performance has increased to a point where i can reliably open up a terminal without having to hardreboot a couple times in a row but its still far from usable

took a new htop

The title of this thread got my hopes up. Only to be crushed… :rofl:


If you create a new user, does that help?

Dawn of the Living Gnome:

creating a new user didnt solve the issue either unfortunatly

Then boot into KDE, remove everything Gnome and reinstall all of the packages again. If that doesn’t work, consider a full reinstall (10-15 minutes, versus hours trying to find the problem).

i saw issues like that after the update to 45… not that badly… but still…

strangle i was reinstalling all packages for the gnome install what solved the issues i had…

sudo pacman -Scc
eos-packagelist --install "GNOME-Desktop"

<could be there is some hidden package issue. . . . .

1 Like

doesnt work either

cant really afford a reinstall since a lot of work stuff is on this pc that i cant get again like special software in my vms and stuff

Yes, a bit confusing …

Thought first, @Kresimir had written that :wink: .

hardware inxi -Fxxc0z | eos-sendlog

you can watch journal messages live with the following command, maybe you notice something weird journalctl -f -p 7

1 Like