Gnome-control-center: missing


I’am having a problem with gnome-control-center.
It just won’t start.

So… o try via terminal and got this message: “gnome-control-center: error while loading shared libraries: cannot open shared object file: No such file or directory”.

Than i opened at Gnome’s gitlab issue report and a answer: “If your Linux distribution failed to properly package gnome-control-center and its dependencies for you, then please contact your Linux distribution instead.”.

Any ideas?

I should probably just reinstall Endeavous right?

Thank you.

I am currently on an EndeavourOS Gnome install. Just tried launching gnome-control-center both from app launcher (settings) and as well from terminal so it isn’t an installation issue per se. Did you do some customizing of the package install or general install that would cause this package to no longer be there?

Ty for the reply.

Just a did a simple EndeavourOS Gnome install.

Do be honest i dont how to customize a package (lol). But ill remove some extentions (dash to panel, etc) to test.

Ahh - the only thing that i did was the include Chaotic repositories.


I would say, system is not properly updated, could be caused by outdated mirror in the list.

  • update mirrors → welcome-app can do
  • fully update system —> sudo pacman -Syyu


Unless you really need a package that is pre-built on that repo (or using garuda Linux) there really is no reason to use it with EndeavourOS.

1 Like

I really don’t know why i use Chaotic - no special reason, but never had any problens.

I ll mark this problem as solved thnks to you.

Just to finish this thread off, this error is down to you performing a partial upgrade.


I cant remenber doing that ( pacman -sy or similar) but it was my fault (for sure - lol)

Ill keep that (partial update) in mind and keep it simples.


1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.