Gnome and Tweaks, autostart applications

Good morning everyone,

my new PC is now a few weeks old, and by trying Gnome before buying I decided to switch to it, as it is really nice. AMD works well, Wayland is running smoothly (even in gaming), I can hardly complain.

So let me complain for a bit. This is one of the minute problems I have with my new Gnome driven PC.

I like to start some applications when I sign into my machine. I installed Gnome Tweaks (called “Optimierungen” here in Weißwurstland) and set up all my applications to autostart:

One of the applications I would like to autostart is the magnificent Freetube, a privacy oriented local only Youtube frontend (check it out if you value your privacy!). However, let me tell you how that went.

The first think I discovered was that whenever Freetube was autostarted the design was light, while I wanted it dark. Closing the autostarted version down and starting it from the menu opened a dark themed version. I thought that strange but set the autostarted version to dark and tried to forget that little strangeness.

However, using the Mozilla Firefox extension Freetube Redirect which always worked like a charm now didn’t. While Freetube (the autostarted version) was running, clicking a link in Firefox opened a second version of Freetube and played the video there.

I discovered that this happened only with the autostarted version of Freetube. Manually starting Freetube, then using a link in Firefox works normally.

This is one of the strange problems I have with my new PC. If anyone can shed some light on this, maybe illustrating the difference between an autostarted version of a program and a manually started one, I’d be grateful.

This is the version I have installed:

aur/freetube-bin 0.21.0-1 (+162 8.67) (Installiert)
    An open source desktop YouTube player built with privacy in mind.

Maybe it is that the autostarted programs are handled as systemd services, created by systemd autostart generator, whose unit files are stored somewhere in $XDG_RUNTIME_DIR and prefixed with app-.

systemctl --user list-unit-files | grep app-

Just a thought. :man_shrugging: