GNOME 43 is Here. What's Working, What's Not?

You got me there :stuck_out_tongue_winking_eye:

It might depend on what version of gtk4 is included on f37/rawhide. I have a VM with rawhide, so I can do do some testing there. for reference, on EndeavourOS my current version is gtk4 1:4.8.2-1 … it looks like the latest version on Rawhide is gtk4-4.8.1-2.fc38.x86_64 … so I think I have:
EndeavourOS → gtk4 4.8.2
Rawhide → gtk4 4,8,1

… and I do get the same behavior in Rawhide. Based solely on the symptoms, it looks like rapid scrolling with the mouse wheel might be confusing or corrupting some index in gtk list view object.


You could also check here:

Release Stable version Version in testing
Fedora 38 gtk4-4.8.1-2.fc38
Fedora 37 gtk4-4.8.1-2.fc37

So perhaps this might be the root cause?

Even though I initially couldn’t reproduce the issue, strange as it might sound, I am seeing the same behavior now :blush::sweat_smile:

yes. I can confirm. I tried it with /usr/bin. Some wheel moves are good and others bring you directly to the bottom of the list.

MEGAsync and nautlius-megasync is my list on what’s not working.


I will uninstall them and reinstall to see if it makes a difference, but it’s not looking good for megasync or the Gnome Files 43 integration, which was so convenient.

Mega hasnt updated that extension in 4yrs, Nautilus had some major changes for Gnome 43 so they may need to update it.

I know, but it worked on 42. The Mega browser extension works, so I will just wait. Hopefully it’s not 4 years as I recall getting a support email on this that they do not support Arch.

But the funny thing is it worked all that time until 43 hit. I tried it on Xorg and same thing. I think it’s broken with this last error.
megasync from 2022-11-06 22-03-56
Is there a way to fix the PKGBUILD?


reading the full output can hint in cases… i already sy one hint:

local/icu 72.1-1
    International Components for Unicode library

Edit2: if you’re getting a build error re icu71, you need to rebuild libpdfium against the latest version of icu. that resolves the build issue.



megasync and the mautilus integration work fine for me.

You need to recreate the megasync package

paru -S megasync --rebuild=all

This works the same way with yay instead or paru


uh nice option:
--rebuildall Always build all AUR packages
will do the job automatically…

Good to know. Same errors.

That’s really good to know.

megasync depend on one of:

libpdfium (libpdfium-nojs, pdfium-binaries, pdfium-binaries-v8)

what do you use?

Caution! There still exist gazillion bytes of illegal copies of music, videos, and the like on MEGA.

If you don’t want to get raided just like Kim-DotCom, stay in tune with your national /local law.
Unhappy to “report” this, I am.

paru -Ss libpdfium-nojs
aur/libpdfium-nojs 5060.r1.558516c323-1 [+22 ~1.03] [Installed: 5112.r1.c7c276ce11-1]
    Open-source PDF rendering engine.

Should I try a different one?

yes indeed only for science, not for real usage.
And do not try this at home!
It is also gone off the topic.

thread a different thread would be good …

Absolutely. Here it is MEGAsync and nautilus-megasync Stopped Working