GNOME 42 Wayland Touchscreen Issues

After fixing my initial issues with GNOME 42’s sluggish performance with extensions installed on my Surface Pro 8, which was caused by an unneeded environmental variable, I am running into other issues with GNOME 42, particular with Wayland and touchscreen input.

I need access to and the ability to interact with system tray icons for applications that I use everyday like Steam, Microsoft Teams, Prospect Email (Outlook Client), Discord, and (to some extent) Cider. I installed Tray Icons: Reloaded, which works great with a mouse/trackpad, but doesn’t support touchscreen input at all in GNOME Wayland, and doesn’t have right-click touch input in GNOME Xorg.

I have also noticed that long-press right click touch support doesn’t work on the desktop or in Nautilus on GNOME Wayland. I also can’t drag and drop folders or files in Nautilus using touch in GNOME Wayland. This means that I can’t use GNOME Wayland or Xorg fully without a mouse/touchpad attached. This kind of defeats the purpose of having a tablet (Surface Pro 8).

If anyone knows how to fix these issues, please let me know. I don’t think these are EndeavousOS specific. However, whatever fix you recommend of course has to work with GNOME 42 in EndeavourOS.

Try https://extensions.gnome.org/extension/615/appindicator-support/ , it seems more reliable to me.

Dude, you are a life savior! It works great, especially with a touch screen in Wayland! Awesome!

Now do you have any suggestions on how I can fix long press right-click support in Nautilus and (not as important) the GNOME desktop? Actually, scratch that. I’ll just use Dolphin, since it works fine with touch even in GNOME Wayland and already has a lot of the features I use that are missing in Nautilus. I just need to figure out how to make Dolphin look native in GNOME.

One other minor issue. I’m using a HiDPI screen and Steam seems to be ignoring GNOME’s scaling factor. Is there a quick way to fix that?

1 Like

Works for me, maybe check your other extensions.

You can have 100% or 200%.

image

So the Desktop Icons NG (DING) extension was inhibiting the long press to right-click on the desktop. Sigh! Yet another extension I need that causes some unwanted shell issues.

I don’t know what’s going on with Nautilus. However, I don’t really care anymore! I was able to fix all of the KDE Plasma applications looking crappy in GNOME by setting the following environmental variable export QT_QPA_PLATFORMTHEME=‘kde’. This is what Dolphin looks like now on my GNOME desktop:

image

Sweet Jesus! I am never going back to Nautilus on GNOME!

jonathon, I also looked at my Steam settings and the “Enlarge text and icons based on monitor size (requires restart)” was already checked. Unchecking it and launching Steam doesn’t change anything, and checking it and relaunching Steam doesn’t change anything either.

image

I also checked in Settings. My display is set at 200%. I don’t know what’s happening. I’ll google this some more, but so far I have a working GNOME desktop that supports 99.9% of what I want or need to do. I’m happy for now. Let’s just hope GNOME developers don’t decide to make any changes that will eventually break my system down the line.

image

Ok, I “fixed” Steam in GNOME by adding “env GDK_SCALE=2” to the "Exec= " line in Steam. GNOME is working out well so far!

image

Ugh! So setting the variable in the .desktop file only works when I launch the Steam application itself. It doesn’t work when Steam is launched by a game’s launcher. Why is this so darn hard?