Gnome 42 Bugs

Then you are safe :smile: .
Maybe it’s a cache related thing.
You can report upstream, if it isn’t already reported.

can i “delete” this manually?

Thankyou for being the guinea pig, so we don’t have to :grimacing:
I am on 41 with Wayland using mesa integrated video. I figure next month I will switch.
Does it sound like a plan?
Great work!

1 Like

I have no idea.
I use Bspwm. I was just curious and gave it a sync (=guinea pig) :grin:

1 Like

Took a leap of faith and installed Gnome 42. So far so good.
My needs are pretty simple, so I don’t expect too much drama. It’s happily using Wayland on Gnome.
Then again, I have Dalto’s Btrfs Assistant, so to restore a snaphot is only a few mouse clicks :smiley: :camera_flash:

3 Likes

I’m seeing an issue where in the “Appearance” settings, I see the light vs dark mode selection, but I’m missing almost all of the other options underneath it, including accent colors. I’m using Wayland and I saw this post where someone else had a similar issue and fixed it by installing the gnome-control-center. I tried that and rebooted, but no luck. Anyone else seeing this or have any ideas?

1 Like


This is how mine looks currently.

Gnome 42 only displays Light/Dark style selector, and a collection of Gnome Wallpapers and/or wallpapers that you have added and that’s it for Gnome 42 currently. Now you might have seen news from Ubuntu 22.04 that has their own “accent color” feature they’ve included only for their distro though, it’s not a feature that’s been implemented upstream yet, but Gnome devs are going to implement an accent color (maybe) and recoloring API in Gnome 43, so if you’re desperate for accent colors you’ll want Ubuntu’s latest release.

If you want any of the included Gnome backgrounds, you’ll need the gnome-backgrounds package:

sudo pacman -S gnome-backgrounds

And it’ll look something like this:

3 Likes

I’m not so sure if it’s a bug, or still catching up with yet to be implemented technologies in Gnome 42.

Warning: Ignoring XDG_SESSION_TYPE=wayland on Gnome. Use QT_QPA_PLATFORM=wayland to run on Wayland anyway.
Qt: Session management error: None of the authentication protocols specified are supported
Btrfs Assistant 1.3

WHat d you think?

I have to say after spending some time setting up Gnome 42, I am really impressed. Using multiple desktops my productivity has skyrocketed. It has not missed a beat, and I have worked it pretty hard. It is using a fraction of the resources of KDE.

Gnome :man_shrugging:

1 Like

If that is a Btrfs Assistant error message, then perhaps opening a new thread and pinging the user @dalto would help, since he is the one that created/maintains it. My only guess is that that error would depend on if using Xorg or Wayland, but other than that I would no be so sure.

@ricklinux thank you graciously for your continual vigorous testing of Gnome in (checks notes) a VM :joy:

1 Like

Thanks Scotty, I posted it to him too, but on the chance it is Gnome 42 related, then either way I expect to learn from it.

1 Like

Is this a bug?

I also notice the gear icon at the DM no longer shows Wayland, and Neofetch reports the WM as Mutter.

Yet About Gnome shows Wayland.

image

Am I missing some extensions, or maybe I should be a little patient with Gnome…

Isn’t that the gnome software/app center. That won’t work on Arch. Same with Discover on Plasma. There are GUI software managers like pamac that can be used on Arch.

1 Like

yes

So I need to update Gnome packages in the Manjaro GUI, pamac-aur?

Do you not use pamac on Gnome?

You can use the terminal

sudo pacman -Syu

Or yay if you use AUR packages.

It is possible to install pamac but there are mixed ideas about this on the forum. I don’t know if it is in the arch repo or AUR. Also check the forum because someone was talking recently about pamac bug on gnome 42 (see post linked below).

Here is a good read about graphical installers.

1 Like

It’ll only show updates for any flatpacks you’ve installed

1 Like

You mean the gnome app right? But you can’t install or update software in there on arch like Ubuntu etc. Correct?

1 Like

That was the post about bug and pamac on gnome which seems partly fixed…

1 Like

If you’ve installed flatpacks from the gnome store they’ll be in the gnome store for updates…

Pamac will pick up arc & AUR updates, I just run yay for those

1 Like