Global menu not appearing for certain applications

After the update to Plasma 6 several applications are missing the global menu. The global menu previously worked for these apps in Plasma 5. The two apps I have noticed so far are LibreOffice and k3b.

For gtk apps like libreoffice the global menu won’t work for them see this bug here Seems to be a whole mess in the case of that one. There have been ideas bounced around on how they can work around it, but nothing has been done so far. For k3b, seems to still be on Qt5, so perhaps you need to install plasma5integration.

How do I install plasma5integration? It’s not in the repos.

Sorry I forgot the dash. It’s plasma5-integration. It is in the repos.

Ah! I should have figured that out. Thank you!

No problem.

That did the trick. K3b is working again. Thanks for your help!

1 Like

Make sure to mark the post that fixed it as the solution to help others in the future.

Consider it done.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.