Gimp xcf file issue

first off, i haven’t dealt with gimp for a long time, so i have only now noticed a small problem.

version 2.10 has introduced a new method to store xcf files with zlib comression, rendering all files unreadable on my system (except for gimp - tested with xnviewmp, gwenview, okular and even with irfanview/wine).

as a workaround, it is still possible to resave xcf files in legacy mode, which is not the ideal, but bypasses the problem.

this version was released about 2 years ago if i am not mistaken, which makes me wonder if you run into similar problems, still?

Have you tried exporting them as a different format as opposed to saving? I usually do this to create .png and .svg files to open in Inkscape.

sure, export is possible, but in order to obtain all relevant data you need to save in gimp’s native project format, which still works, but only in legacy mode.

perhaps the new format is just not ready yet?

As far as I could find out these images can’t even be read by older gimp versions. Keeping all this, you call it relevant data, could all of the time only be used by gimp itself. These are only needed, if you want to continue editing these images with gimp. Other programs could display the images but could not use the extra data.
I had a quick look in the settings and I think it’s possible to use the old format as default.

Edit : I just did a test and saved a small image using xcf. XnViewMP was able to display it without any problems. I can confirm that Okular is unable to open it. Gwenview is not installed on my system.

I doubt that. I’m sure it is ready. It’s not the gimp developers’ fault if other developers haven’t implemented that format yet in their programs.

1 Like

excactly, i keep xcfs as master files for the said reason. usually they can be opened outside of gimp without worries. the exports are quickly done from these sources later on, if needed.

now that is very interesting. one possible cause that comes to my mind could be a misconfiguration (custom filter?). i will test with a fresh config and let you know if it helped.

why it also did not work out for irfanview is beyond me…

for now, i just switched back activating the legacy mode.

Maybe the IMXCF plugin is outdated. The last Irfanview update was in December 2019. The new version might not be implemented.
According to homepage :

Version 4.54 ( - CURRENT VERSION - )

(Release date: 2019-12-12)

IMXCF - (version 1.10 ): allows IrfanView to read XCF files (GIMP File Format)

1 Like

you are probably right, as these are also the versions i use.

as far as xnviewmp (aur) is concerned, I unfortunately had no success using a fresh config either.

‘error while opening the file’

i might try with different viewers for the fun of it.

just a short feedback:

imagemagick was unable to open xcfs too. it appears to not support gimp 2.10 xcfs yet:

krita 4.2.9: This XCF file is too new; Krita cannot support XCF files written by GIMP 2.9 or newer.

i will mark it solved, thanks for your helping hands.