Getting "Failed to load module "colorreload-gtk-module" when starting GTK apps from terminal

After I tried the KDE DE alongside my current XFCE DE, I removed all of the packages I’d installed with yay -Rns plasma-meta kde-applications-meta. Now I’m getting this warning whenever an app I run from the terminal starts a GUI: "Failed to load module “colorreload-gtk-module”. When searching for this module, I came up with this:

$ pacman -Fx colorreload-gtk-module
extra/kde-gtk-config 5.23.1-1 (plasma)

which I don’t want to reinstall and was working fine without it before the aborted KDE Plasma attempt. I’ve looked through dconf to see if there was a settings change I could revert, but found nothing. Anyone else have a clue where to begin?

I had these warnings when using XFCE . I think it disappeared after changing themes . Maybe try changing theme :man_shrugging:

While it could be a theme issue, this was working before the install of KDE (and with the current theme). Something changed in a config file somewhere and was not backed out. It’s probably buried in my $HOME/.config, just gotta find it.

UPDATE: as I suspected, the KDE install changed this file:
$HOME/.config/gtk-3.0/settings.ini, adding gtk-modules=colorreload-gtk-module


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.