Getting fail desktop starting with Xrdp

Hi
I did install xrdp and xrdporg over the standard install with xfce. But when log over xrdp it give a somehow black screen with white ttl console window duplicated. From there, if i write directly : startxfce4 , the desktop do start… but what xinit should be put into the : /etc/X11/xinit/xinitrc ?

I seen another post that is quite the same and for a desktop : plasma :
https://forum.endeavouros.com/t/use-xrdp-to-open-a-session-in-lan/25427/8

it was just to remove the last 5 line of the file and put instead :

export DESKTOP_SESSION=plasma
exec startplasma-x11

But i did try with:

export DESKTOP_SESSION=xfce4
exec startxfce4

or
export DESKTOP_SESSION=xfce4-session
or
export DESKTOP_SESSION=startxfce4
exec startxfce4

But this all result into an error message of :
unable to contact settings server / could not connect: connection refused

And if no change to the : /etc/X11/xinit/xinitrc and then doing this :

echo startxfce4 >> ~/.xinitrc
this still give the same error.

Thanks for help, probably something small missing…

You are probably misunderstanding something. The above description doesn’t exactly make sense.

It would be better if you described what do you want to accomplish, so you get the best advice.

The linked post’s advice was plasma-desktop specific.

Indeed, so this was quite related as the other post. I install xrdp, but while the previous solution was plasma-desktop , what can be the solution for xfce desktop ?
with : xrdp xorgxrdp , you log in and you get this :

I was expecting an answer to my question, not to your question. :laughing:

And what you call xrdp, xorgxrdp I have no idea what you may mean. Do you mean xrdb and if so, why do you mess with this?
But first answer the question :point_up:

Oh… hehe sorry. xrdp as the remote access. I want to load the desktop x11 gui directly and not having to write into those white console : startxfce4.
As on the install it was with :
yay -S xrdp xorgxrdp
sudo systemctl enable --now xrdp

log over remote desktop , put the EndeavourOs U/P and then direct to this white console.

It only needs the exec command. Have you tried it (in ~/.xinitrc)?

exec startxfce4

If it fails, follow any xrdp related troubleshooting in Archwiki and report what you did and failed.

Well, as written, this is the first test as all centos and other get started with this simple line.
For now after 4hr … quite different but we can get it to for another session using : dbus-launch --syntax startxfce4 but i will try to find out how to get a proper same session restore.

1 Like