Getting "ACPI Error: No handler for Region [RCM0] " at the boot time

i am using hp-15bs145tu machine and the latest build of endeavour os with lts kernel and i3-wm, and at the boot time i am getting this error,

Sep 30 11:44:41 bhanu-Arch kernel: ACPI Error: No handler for Region [RCM0] (000000003e74d928) [SystemCMOS] (20200925/evregion-129)
Sep 30 11:44:41 bhanu-Arch kernel: ACPI Error: Region SystemCMOS (ID=5) has no handler (20200925/exfldio-261)
Sep 30 11:44:41 bhanu-Arch kernel: ACPI Error: Aborting method _SB.WMID.ESDT due to previous error (AE_NOT_EXIST) (20200925/psparse-529)
Sep 30 11:44:41 bhanu-Arch kernel: ACPI Error: Aborting method _SB.PCI0.LPCB.EC0._Q42 due to previous error (AE_NOT_EXIST) (20200925/psparse-529)

more specifically, whenever i boot with the upstream kernel, my kernel goes into a panic, and i am unable to use the upstream kernel at all.

Note : I am already using the updated bios, and one more thing is, all the bios for my machine is officially for the windows os and there is no support for linux from my manufacture which is HP and bios manufacturer is Insyde.

Also the hibernate mode in not working at all, Apart from this my laptop is working good at least till now.

Thanks Endeavour os team.

further adding to the bug list or error list, the errors which keeps upstream kernel panics are below :

Sep 30 20:42:41 bhanu-Arch kernel: rcu: INFO: rcu_preempt detected stalls on CPUs/tasks:
Sep 30 20:42:41 bhanu-Arch kernel: rcu: Tasks blocked on level-0 rcu_node (CPUs 0-7): P1925/1:b…l
Sep 30 20:42:58 bhanu-Arch kernel: rcu: INFO: rcu_preempt detected expedited stalls on CPUs/tasks: { P1925 } 18060 jiffies s: 181 root: 0x0/T
Sep 30 20:42:58 bhanu-Arch kernel: rcu: blocking rcu_node structures (internal RCU debug):
Sep 30 20:43:56 bhanu-Arch kernel: ACPI Error: No handler for Region [RCM0] (0000000021cd05e6) [SystemCMOS] (20210604/evregion-130)
Sep 30 20:43:56 bhanu-Arch kernel: ACPI Error: Region SystemCMOS (ID=5) has no handler (20210604/exfldio-261)
Sep 30 20:43:56 bhanu-Arch kernel: ACPI Error: Aborting method _SB.WMID.ESDT due to previous error (AE_NOT_EXIST) (20210604/psparse-529)
Sep 30 20:43:56 bhanu-Arch kernel: ACPI Error: Aborting method _SB.PCI0.LPCB.EC0._Q42 due to previous error (AE_NOT_EXIST) (20210604/psparse-529)
Sep 30 20:44:35 bhanu-Arch kernel: i915 0000:00:02.0: [drm] ERROR CPU pipe A FIFO underrun

Posting in hope, that it might help someone to debug and tell me what is the issue with my machine and how can i fix it.

Welcome @Bhanu
Did you update the Bios using Windows? What is the version and date?

This error message indicates ACPI errors that reports the hardware isn’t responding to the ACPI and has problems interacting with it.

There are a number of kernel parameters you might try.


Or set the acpi to the version of Windows that was or is installed.

This does boil down to poor implementation of ACPI in Bios and is quite common. You say you are having kernel panics with upstream kernel? Do you mean the current kernel? Are you using the lts kernel then?

Please post your hardware log

inxi -Faz --no-host | eos-sendlog

You could also provide the following boot log

journalctl -b -0 | eos-sendlog

Here are instructions for providing logs. In case you aren’t aware EOS has log tools built right into the Welcome screen. Also please use code tags when pasting info from terminal as it is much easier to read.

You can provide logs in other ways too.

1 Like

Thank you sir for your reply, I am working on the suggestions provided by you, and will post them asap in this thread.

Moreover, some things that I already tried are as follows :

  1. putting acpi=off make the laptop keyboard unusable though the external keyboard works, though the error has gone(but can’t use the laptop like this).

  2. I send the logs as guided by you.

  3. No sir, I didn’t update bios with windows, I always used USB, since Hp doesn’t provide bios supported for Linux for my machine, therefore I have to make Bios bootable USB(through windows pc) to update my bios.

  4. My Bios version is ‘F.68’ provided by ‘Insyde’ through ‘HP official website’, and it is the latest bios available for my machine, at present.

  5. Yes sir I am having the kernel panic with the current kernel and right now I am using the ‘lts’ kernel which is working good, apart from the ‘hibernate’ feature, earlier also I used vanilla arch with ‘lts’ kernel but there, I am also facing the issue of system freeze when resume from suspend state.

Thanks to your team, that I am not having that issue till now, with lts kernel in endeavouros.

What I am understanding with my little knowledge and weeks of debugging is that I am having poor implementation of ‘Acpi’, but the problem is, I am not capable enough to patch my ‘DSDT’ and 'SSDT’s.

Bios version looks correct.

Do by posting hardware log : you mean posting the link that i get( after posting the log), in this forum, if yes :

Then log after inxi -Faz --no-hosting | eos-sendlog is at

And after journalctl -b -0 | eos-sendlog is at

Yes this i one way of doing it. It uploads the the file and gives the link. The logtool is very similar from the welcome app.

Thank you for letting me know.

I do want you to read through the ACPI Kernel Parameters link i provided above. It would be good to try a kernel parameter that is like the following. This is more to do with the ACPI error messages than anything. Not sure how it will affect the kernel panic situation.

acpi_osi='Windows 2020'

ok sir, i will try all the options and tell you back

Also maybe you can give a link to this command.

sudo dmesg | eos-sendlog

ok sir, here it is :

In dmesg i only see the following which really are harmless error messages related to ACPI

6.054781] ACPI Error: No handler for Region [RCM0] (000000008becf6cf) [SystemCMOS] (20200925/evregion-129)
[    6.054787] ACPI Error: Region SystemCMOS (ID=5) has no handler (20200925/exfldio-261)
[    6.054793] ACPI Error: Aborting method \_SB.WMID.ESDT due to previous error (AE_NOT_EXIST) (20200925/psparse-529)
[    6.054800] ACPI Error: Aborting method \_SB.PCI0.LPCB.EC0._Q42 due to previous error (AE_NOT_EXIST) (20200925/psparse-529)

I also notice them in the boot log but these shouldn’t be concerning. They are pretty normal error messages that are quite common. A lot of vendors don’t do a very good job with the Bios and ACPI implementation. You have the latest Bios version also.

Is the computer working okay with the lts kernel? When you installed did you select hibernation with swap? I find that my HP doesn’t do hibernation well either. It does work well with suspend mode though and closing the lid. That is about the only thing you can do other than trying an install of a different desktop that might have a different experience. I don’t really see too much in any of the logs that jump out at me as being an issue.

I don’t think the ACPI error messages are the cause of any of the issues. Just my opinion. If you stay on the current path i guess trying updated kernels periodically. As far as the kernel panics go i can’t really help too much. I myself am running the latest kernel. I have never been an lts kernel user much myself.

If I’m not mistaken by the log you are using i3? Maybe others can also look at the logs and see if i miss anything or they have other ideas.
I do have one idea to blacklist a module for the ACPI error messages but i don’t feel it will have any benefit in doing that.

Edit: Maybe someone else can help you with settings for suspend and or hibernation.

yes sir computer is working okay with lts kernel,
yes i am using i3, and i am not sure about selecting the ‘hibernation with swap’, basically i did the normal installation using the endeavouros as well the same steps as shown by ‘EFIlinux’ youtube channel regarding the installation of endeavouros, thus i don’t think so, that i tinker anything while installation.

may i know your idea of blacklisting the module, that you are talking about, cause weeks backs when i was debugging the issue, i had come across with some post on red-hat forum regarding acpi error(though not the same as the one i has, apart from ‘AE doesn’t exist’ part), and the solution there is just to blacklist that module.

update :
putting ‘acpi=off’ as kernel parameter, in current(upstream kernel), stops the kernel panics.
but yes internal keyboard and mouse doesn’t work, external one does.

Did you try using

acpi_osi='Windows 2020'

Or one near the year of the laptops manufacture.

yes sir, i have tried it, and also all the other options given in the article suggested by you, no succes.

No success meaning exactly what?

i mean acpi errors remain present in lts kernel and upstream kernel still panics after boot.

As i said before i wouldn’t worry about the error messages on the lts kernel. They are more informational than a problem IMHO. The panics on current kernel you would have to narrow down to errors when loading that kernel in whatever logs you could look at. These are caused by kernel/hardware related issues and also possibly bios related? You have the most current Bios updates so the best thing is to try to find others with same hardware and see if you can find any solutions.