General error when importing mullvad-vpn key with gpg

Good morning,

I am trying to install ‘mullvad-vpn’ and then I get the following error:

:: PGP keys need importing:
 -> EA0A77BF9E115615FC3BD8BC7653B940E494FE87, required by: mullvad-vpn
==> Import? [Y/n] y
:: Importing keys with gpg...
gpg: keyserver receive failed: General error

I ducked around but have yet to find a solution so now I am asking here.

try manually import it:

gpg --recv-keys --keyserver hkp://keyserver.ubuntu.com:80

2 Likes

I pasted that line in the terminal and then I tried installing again but I get the same error.

The main keyserver pool used my most Linux distros has failed to renew their SSL certificate. Before installing the AUR package, run

gpg --keyserver hkps://keys.mozilla.org --recv-keys EA0A77BF9E115615FC3BD8BC7653B940E494FE87

The previous person who tried to help assumed you knew to append the key you are importing to the end of the command.

1 Like

https://aur.archlinux.org/packages/mullvad-vpn/

Yes, after his line I found a page on Arch where the line was slightly different and is the same as yours @ben781 and that worked!

Another thing I learned and this is going to my Linux notes document. Thanks all!

1 Like

Oh sorry I thought I pasted the key there but seems I didn’t. I’ll go into the Blame corner :laughing:

4 Likes

You forgot an s …hkps

3 Likes

Such things happen to the best… I mean, I’ve done similar typos myself. :wink: :sweat_smile:

1 Like