GeForce GTX 880M Bumblebee

First post here, I have a laptop with optimus hybrid card (GTX 880M) and I’ve not been able to get it to work, I followed this guide to the letter and I don’t know what went wrong

Bumblebee for NVIDIA Optimus (older systems)

Here’s the inxi -Ga output

  Device-1: Intel 4th Gen Core Processor Integrated Graphics
    vendor: CLEVO/KAPOK driver: i915 v: kernel arch: Gen5.75
    process: Intel 45nm built: 2010 ports: active: eDP-1
    empty: DP-1, DP-2, HDMI-A-1, HDMI-A-2, HDMI-A-3 bus-ID: 00:02.0
    chip-ID: 8086:0416 class-ID: 0300
  Device-2: NVIDIA GK104M [GeForce GTX 880M] vendor: CLEVO/KAPOK
    driver: N/A alternate: nouveau, nvidia_drm, nvidia non-free: 470.xx+
    status: legacy-active (EOL~2023/24) arch: Kepler process: TSMC 28nm
    built: 2012-18 pcie: speed: Unknown lanes: 63 link-max: gen: 6
    speed: 64 GT/s bus-ID: 01:00.0 chip-ID: 10de:1198 class-ID: 0300
  Device-3: Acer BisonCam NB Pro type: USB driver: uvcvideo bus-ID: 3-10:7
    chip-ID: 5986:055c class-ID: 0e02 serial: 200901010001
  Display: x11 server: X.Org v: 21.1.3 compositor: kwin_x11 driver: X:
    loaded: intel unloaded: modesetting alternate: fbdev,vesa gpu: i915
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
    s-diag: 582mm (22.93")
  Monitor-1: eDP-1 mapped: eDP1 model: ChiMei InnoLux 0x15b1 built: 2012
    res: 1920x1080 hz: 60 dpi: 143 gamma: 1.2 size: 340x190mm (13.39x7.48")
    diag: 395mm (15.5") ratio: 16:9 modes: 1920x1080
  OpenGL: renderer: Mesa Intel HD Graphics 4600 (HSW GT2)
    v: 4.6 Mesa 22.1.2 direct render: Yes

Here’s my optirun --status

Bumblebee status: Ready (3.2.1). X inactive. Discrete video card is off.

nvidia-installer-check is not recognized as a command

hope someone can help.

Welcome to the forum @vnavah!

Welcome aboard! :smile:

There’s a typo in the linked instructions. To fully upgrade the system, run command

yay   # not yay -Syua

You might want to try a CLI program nvidia-inst.

nvidia-inst -h

for some help, and search for nvidia-inst related posts here for more help.

Hi, thanks for the help, I read through the whole post, and for what I understand those instructions work for nvidia graphics card, but from what I read in these forums it may wont work for an optimus nvidia hybrid card and also my card is a bit old, like 7 years old :crazy_face:, so from what Ive been reading, I might need to configure the 390 driver with Bumblebee, Im I right?

Looks like Nvidia 390 series driver is the one to use:

$ nvidia-driver-supported-branches 1198
NVIDIA card id: 1198
The nvidia-dkms version: 515.48.07-2
Series 390: supported (Nvidia: 390.151)

More info:

This is supported by nvidia-inst. It should be able to install bumblebee as well, simply look at the options (especially --bumblebee) of nvidia-inst.

So, I got it working, I just ended up using optimus switch.
I started following this guide
Arfter runing

pacman -Q | grep nvidia

from the first steps, I fount out that even with the nvidia propietary install, no drivers where installed, neither the nvidia-installer-dkms.
So I started by runing

sudo pacman -S nvidia-installer-dkms

and runing the dkms by force

sudo nvidia-installer-dkms --force

On step 8, I didnt restart, I run

pacman -Q | grep nvidia

again, and manually remove all entries but
nvidia-installer-common 1.3-1
nvidia-installer-db 2.5.8-1
nvidia-installer-dkms 3.5-1
did a reboot and ended up with ​ “Reached target Graphical Interface” a blinking cursor so I started the system on TTY 3 and went ahead and installed
nvidia-390xx 390.151-1
nvidia-390xx-dkms 390.151-2
nvidia-390xx-utils 390.151-2
and thats it, I got it working.
Thanks to all for the help!!!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.