GDM shows only GNOME and GNOME classic after boot/reboot

Hi there,

after a boot/reboot I can only select GNOME or GNOME classic in GDM, where the GNOME session is on Xorg apparently. After logout/login I can select GNOME, GNOME classic and GNOME on Xorg, where GNOME is on wayland. Any idea why this choice is not being offered after boot/reboot?

Thanks in advance,


hello,I know that with a nvidia graphic card, you don’t have gnome under wayland

I’m not on nvidia:

[csteinforth@E14 ~]$ lspci -k | grep -A 2 -E "(VGA|3D)"
00:02.0 VGA compatible controller: Intel Corporation UHD Graphics (rev 02)
	Subsystem: Lenovo Device 5079
	Kernel driver in use: i915

But on Arch wiki I found this. So I added i915 to the MODULES section in mkinitcpio.conf. After regenerating initramfs and reboot the three options (‘GNOME’, ‘GNOME classic’ and ‘GNOME on Xorg’) are there in GDM, and GNOME session is on wayland May switchting to early KMS start have any side effects?

I tested this one again with the linux-lts kernel, and here it worked without switching to early KMS.