GDM hangs for a while and problems after logging in

After booting GDM hangs, showing grey and just the time at the top, for a while but eventually shows my user selection. On Wayland the shell loads and I can see my desktop but it’s totally unresponsive. On Xorg it’s black for a long time and if I wait it will eventually give me an error that saying it failed and I need to log out, but the logoit button is unresponsive. I can access the tty3 though and did a couple of commands with eos-sendlog:

This is a new install and for a while it worked okay. I didn’t have some trouble with System76 drivers and their specific stuff (specifically Bluetooth and their system76-power cli tool) and had to play with some packages and systems services, so it’s possible I caused this problem during that and didn’t notice until my next reboot. Other than a recent update I don’t have any other clues. I did see the news update about the exec start in my .bash_profile file but I also have issues in Xorg. I still checked and I don’t have the exec xstart command in the file at all.

Not sure if bumping is allowed here, but I still haven’t found a solution. I’ve been without my laptop for almost a week now and will have to consider a reinstall soon if I can’t get this working, which I would really like to avoid. I managed to get into x11, but it’s buggy. I tried to find that post about x11 working but wayland not and it seems to have been removed, so I have no idea what I can do at this point.

I installed xfce4 and it works with no issues at all. GDM still hangs for a while before I can interact but I can select xfce and log into it from gdm. Whatever the issue is it seems to be effecting gnome and gdm only.

Well, normally I’d recommend trying with the LTS kernel, but right now the LTS is the same as mainline. Actually, right now it’s more recent ! 6.6.11 vs 6.6.10. But you could downgrade to 6.1.71-lts and see if that works?

I had an HP laptop recently that booted into a Plasma black screen on anything 6.6. Maybe tangentially related to your problem?

Thanks for the reply! Um so I’m a little confused. I rebooted and on the systemd-boot screen it only had 2 kernel options: 6.7 and 6.7-fallback
I selected the fallback one just to see what would happen, and gnome wayland logs me in but there’s no gnome-shell, just app windows. I installed the EndeavourOS Simple kernel manager and following is a screenshot of what it looks like.

So if I’m seeing this correctly I’m on 6.7 as mainline and installed but you’re saying 6.6.11 should be the mainline?

I figured I would just try the lts kernel that was listed in akm, so I checked both the lts and lts-headers for 6.6.11-2 and rebooted. GDM still hangs and gnome on wayland still didn’t load a shell (meaning the top bar or the overview), like on the 6.7-fallback. I could try 6.1 but I installed endeavour on this laptop not very long ago so I’m pretty sure I already had a kernel passed 6.1 when it was working.

At the time I wrote my answer, it was. linux was updated yesterday 2024-01-14 22:41 UTC, I assume from 6.6.10 to 6.7.
6.6.11 was never in the mainline at all, apparently.

Then you can try downgrading linux and linux-headers to some version that used to work. (downgrade command from eponymous package).

But your problem may not be kernel related at all; I only mentioned that because I had a superficially similar problem with KDE that definitely was.

If kernel alone does not suffice, you can downgrade everything to a time when things worked. To do that, use the eos-shifttime command, from package eos-bash-shared.

Well, I managed to get x11 to work. Not really sure what I did. I just kept uninstalling packages I remembered installing and rebooting. GDM still has a delay before it reacts and wayland will load gnome-shell and a couple of apps I have set to open on start but is unresponsive after that. I’m not really sure if I need to make wayland work or not. I don’t really need it for something specific.