GDM 42.0+r11+g4a52f026-1 Wayland issues

Whats up with that?

Last update with zen kernel updates etc. a new GDM version also was in there.

(42.0-1 => 42.0+r11+g4a52f026-1)

seems like a git version number? Anyway, the problem with this is, that it removes the wayland login option.

I did add GDM to ignorepkg list for now in /etc/pacman.conf

gdm: ignoring package upgrade (42.0-1 => 42.0+r11+g4a52f026-1)

So, does anybody know whats up with this or how to maybe “fix” this issue?

I did try the “Early KMS start” and that didn’t seem to do anything.


Here I get four options when clicking on the cogwheel on the login screen, namely:

Gnome Classic
Gnome Classic on Xorg
Gnome on Xorg

For me it defaults to the first option which is the Wayland session:

$ uname -a 
Linux arch-gnome 5.17.2-zen3-1-zen #1 ZEN SMP PREEMPT Sun, 10 Apr 2022 11:18:34 +0000 x86_64 GNU/Linux

[2022-04-13T19:40:59+0200] [ALPM] upgraded gdm (42.0-1 → 42.0+r11+g4a52f026-1)

1 Like

Sometimes Gnome packages in the Arch repos will have an “inconsistent looking” version number like this, but this is nothing to be concerned about, it is normal to see this from time to time. I would however not recommend holding back any core Gnome packages since partial updates will become problematic sooner than later, unless of course you know exactly what you are doing.

To make Wayland enabled in GDM (it should be the default fyi): open up a terminal using nano, micro, or whichever editor you fancy:/etc/gdm/custom.conf

In my case I’ll just use nano for this example:

sudo nano /etc/gdm/custom.conf

And make sure you have the following line looking like this:

# Uncomment the line below to force the login screen to use Xorg


Chances are maybe yours was uncommented so it was defaulting to Xorg. Just make sure you have a # before WaylandEnable=false and then save it. Log out or reboot and check the cog wheel in the bottom right of GDM while entering your password to see if you can access Wayland again and hopefully then you’ll be all set!

1 Like

Thats what the issue is, no wayland options on login/cogwheel. only xorg und classic.

its like that. commented or uncommented WaylandEnable=true doesnt seem to do anything.

I even tried some other “solutions” like adding new users and all that. Nothing worked so far.

I also removed nvidia dkms and reinstalled them. This also didn’t change anything.

Looks like there were changes to /usr/lib/udev/rules.d/61-gdm.rules to make Wayland support more robust.

The same instructions on the Arch wiki page will work to force-enable Wayland:


This did it.

To force-enable Wayland, disable these rules:

ln -s /dev/null /etc/udev/rules.d/61-gdm.rules

I did this before updating GDM. Now it works again. Thank you!

➜ ~ pacman -Q gdm
gdm 42.0+r11+g4a52f026-1



This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.