Gday Community - Vulkan isnt working with games , need help please

Gday Community

I recently migrated / re installed from Fedora 35 XFCE Classic (NO CSD)
( ) , over to Endvour OS Neo /w XFCE Classic (no CSD)

Ive been into computers from 1991 to 2021, starting out on Amstrad CPC664 (home) and Apple IIc (school)
migrating to Amiga 500 then XT/X86 based systems around 1996-1997

I’ve re-installed the system as much as I can
but have mixed results for video games
working and need some help sorting it out please

Introduction :-

Ive been a supporter of Opensource/Foss , self hosting, privacy, non bloat
Linux, Freedom of Speech, Truth Seeking/Knowledge, facts over feelings.
Even after Ive been called - Anti Goverment, Anti Corporation, insert abuse/terms to silence debate

I advocate for Freedom for all human species without

  • Supression of Truth / knowledge / information
  • International Federal Goverment, World Central banking Cartel, Taxation + Wealth redistrubution
  • Lies, Deciption, Double standards, force, voilence , Coercion
  • Free Market Captialism without Taxation/Goverment/Regulation/unions

I support:

  • Truth, Knowledge, privacy, encyption, self hosting, self suffiency, self reliancy
    along with sound money + currency based on HOURS without Usery & Debt based economy
  • I support the 13 month calander cycle, 24 hour clock

I would self idenity/classify myself as :- Voluntist , Agorist , Cash Only Money ,
Keto+Fasting , Quiet Life , looking into Offgrid, SHTF, Survial, lowtech and woodworking

I use CB radio + LORA + old casio watch, compass+paper map, phone box’s + no mobile phone

My Hardware:-

Custom Built Gaming PC

Video - RX 580 8gb - Asrock
Sound - Presonus Audiobox USB Interface

CPU - AMD Ryzen 3500X 3.6ghz 6 core
Mobo - Gigabyte B450 S2H
RAM - 32gb DDR4

OS - Endvour OS
Kernal - 5.15.10-arch1-1 + libc 2.33
Alsa + pipewire
OpenGL 4.6 + Mesa 21.3.2

Drives - 250 gig samsung NVME (OS+ video content creation)
- 1TB 2.5" SSD (games)
- 4TB USB External (Download/backups/longterm storage)

Screen - 27" IPS 75hz + 24" IPS 75hz



Browser - Web - LibreWolf (appimage)
Browser - Gemini - Lagrange (appimage)
Text Editor - Leafpad (appimage)
Video Editor - Shortcut (appimage)
Sound Editor - Audacity 2.3.1 (appimage)
Office Suite - LibreOffice (appimage)
CPU-X (appimage)
KeePassXC (appimage)

Mumble (pacman -S)
Smplayer (pacman -S)
Dino (pacman -S)
xed (pacman -S)
OBS (pacman -S)
Hardinfo (pacman -S)
nano (pacman -S)
mutt (pacman -S)
wget (pacman -S)
youtube-dl (pacman -S)
mpg123 (pacman -S)
Simple screen recorder (pacman -S)

winFF (yay -s)
libxfce4ui-nocsd (yay -s)

Steam (pacman -S)




  • OpenRA - Combined Arms (Native/Appimage) With OpenGL
  • 0AD (Native/Appimage) with OpenGL


  • ETS2 (Native)

  • Heroes of Hammerwatch (Native)

  • Insurgency (Native)
    While using launch option - LD_PRELOAD=/usr/lib32/ %command%

  • OMD3 (Proton/Wine)

  • Alien Swarm Reactive Drop (Proton/Wine)

  • R6 Seige Offline modes (Proton/Wine) Loads/offline modes work/waiting for Ub!sh1t to get around to contact anti cheat and enable it for Linux online ‘cheat enabled’ play

Crash’s/Doesnt work :

  • World Of Warships (Proton/Wine)
  • Splitgate (Native) (Vulkan) * Brings up UE4 crash dialogue box*
  • Dirt 4 (Native) (Vulkan) * Fails to run, manual stop required *
  • The Ascent (Proton/Wine) * Fails to run, manual stop required *
  • 7D2D (Native) (Can use OpenGL ‘core’ or vulkan via launcher) * Fails to run, manual stop required + double status bar/start menu appears,thus i need to reboot *
  • Road Redemption (Native) *grey screen , no menu, need to force close *

Ive looked into arch wiki, reddit, censortube videos and endvour os forums
I cant seem to get Vulkan and ‘mesa’ working
(eg How to Set Up Arch Linux For Gaming - nVidia, Intel & AMD GPU Drivers, Steam Proton & Lutris How to Set Up Arch Linux For Gaming - nVidia, Intel & AMD GPU Drivers, Steam Proton & Lutris - YouTube )
(eg Linux gaming [Guide] )

I cant seem to find any well documented infomration on using AMD’s driver from its website
instead of the built in opensource/foss drivers

Im willing to post text/picuture or do a video to diganoise the problems

Too many of the guides or help often refer to Ubuntu or Nvidia
and exclude AMD video cards + Arch

People’s Republic of Australia


I would self idenitfy/classify myself as: frequently drunk.

I use Arch, BTW.



Seeing as you are using mesa, I assume you would want to use mesa vulkan.

Do you have the following also installed?

  • vulkan-icd-loader
  • lib32-vulkan-icd-loader
  • lib32-vulkan-radeon
  • vulkan-radeon
  • lib32-mesa

I’ve seen in the past with similar issues sometimes people have mismatched driver versions installed. what do the following give you?
inxi -G
pacman -Qs vulkan
This will give more info as well. But it will be a lot most likely
VK_LOADER_DEBUG=all vulkaninfo

Also, which vulkan driver are you trying to use? Are they all not working? Or just one of them?

  • amdvlk lib32-amdvlk (for AMDVLK Open Source)
  • vulkan-radeon lib32-vulkan-radeon (for RADV included in MESA)
  • vulkan-amdgpu-pro lib32-vulkan-amdgpu-pro (for AMDVLK Closed Source)

You can list your installed vulkan drivers like so:
ls /usr/share/vulkan/icd.d/

Temporarily test them like this:
VK_ICD_FILENAMES=/usr/share/vulkan/icd.d/amd_icd64.json vulkaninfo

Thanks for replying

vulkan-radeon - 21.3.2-1 Yes Already Installed
lib32-vulkan-radeon - 21.3.2-1 Yes Already Installed
lib32-amdvlk - 2021.q4.2-1 Yes Already Installed
amdvlk - 2021.q4.2-1 Yes Already Installed

vulkan-icd-loader - 1.2.202-1 Yes Already Installed
lib32-vulkan-icd-loader - 1.2.202-1 Yes Already Installed
lib32-mesa - 21.3.2-1 Yes Already Installed

  • inxi -G

Device-1: AMD Ellesmere [Radeon RX 470/480/570/570X/580/580X/590]
driver: amdgpu v: kernel
Display: x11 server: X.Org driver: loaded: amdgpu,ati
unloaded: modesetting resolution: 1: 1920x1080 2: 1920x1080
OpenGL: renderer: AMD Radeon RX 580 Series (POLARIS10 DRM 3.42.0
5.15.10-arch1-1 LLVM 13.0.0)
v: 4.6 Mesa 21.3.2

  • pacman -Qs vulkan

local/amdvlk 2021.Q4.2-1
AMD’s standalone Vulkan driver
local/lib32-amdvlk 2021.Q4.2-1
AMD’s standalone Vulkan driver
local/lib32-vulkan-icd-loader 1.2.202-1
Vulkan Installable Client Driver (ICD) Loader (32-bit)
local/lib32-vulkan-radeon 21.3.2-1
Radeon’s Vulkan mesa driver (32-bit)
local/spirv-tools 2021.3-1 (vulkan-devel)
API and commands for processing SPIR-V modules
local/vulkan-icd-loader 1.2.202-1
Vulkan Installable Client Driver (ICD) Loader
local/vulkan-radeon 21.3.2-1
Radeon’s Vulkan mesa driver
local/vulkan-tools 1.2.199-1 (vulkan-devel)
Vulkan Utilities and Tools

  • vulkaninfo


Vulkan Instance Version: 1.2.202
plus a huge amount of text

  • ls /usr/share/vulkan/icd.d/
    amd_icd32.json amd_icd64.json radeon_icd.i686.json radeon_icd.x86_64.json

So, it looks like your Vulkan install is fine. Is Vulkan not working with anything? or just some specific games? When it comes to games on Linux they can be a bit unpredictable. Sometimes the Native version works and Windows/Proton version doesn’t. Sometimes it’s the opposite, and the Native version doesn’t but the Windows/Proton version does. Sometimes one Proton version works for one game and you need another like ProtonGE for another.

You could try -force-Vulkan as a launch option in steam.
Check the ProtonDB for the specific game that’s not working and see if someone else posted a config/launch option.

And have you tried all 3 Vulkan driver versions? Open Source, Closed Source, and Radeon?

It’s not unheard of for Vulkan to not work with some games. Try runing without Vulkan. To use Wine Direct3D instead of DXVK usePROTON_USE_WINED3D=1 as a launch option.

Other launch options can be found here:

Have you tried Lutris? They often have install scripts and pre-configured options associated with their launcher as well.
Here’s some docs that Lutris put together hat may help too:


I attempted using -force-vulkan with Splitgate (UE4)
Didnt work, same error

Note this game worked fine in Fedora with the same PC only a few days ago


Ive never had much luck with Lutris and would rather keep the games within steam eco system

How does one swap between the 3 drivers ?

For that one try it without MANGOHUD first. (If you have it)
Right click your game go to properties in launch options enter this:
MANGOHUD=0 %command%
or as an environment variable from terminal
MANGOHUD=0 steam

You should be able to set the vulkan driver as a game launch option the same way or as an evnironment variable from terminal when you launch steam
Depending what you have installed:
ls /usr/share/vulkan/icd.d
either add as game launch option or export it as an environment variable replacing “amd_icd64.json” with which version you want:
export VK_ICD_FILENAMES=/usr/share/vulkan/icd.d/amd_icd64.json
then launch steam. (this will be temporary for the length of your user session)

or set it at the launch of steam. (temporary for single launch/restart of steam)
VK_ICD_FILENAMES=/usr/share/vulkan/icd.d/amd_icd64.json steam

or set both 32 and 64 bit versions at the same time like this:

you can check current environment variables with this:

MIght want to try ProtonGE as well

Also, launch steam from terminal that might provide more troubleshooting info as well.

I’d recommend using vulkan-radeon instead (so you get RADV).

1 Like

Okay, So I downloaded this one to give it a go got the same crash and found the problem. First It works fine with both AMDVLK and RADV. I didn’t get any performance stats for either of them so don’t know which would be better for this game.

But, after running steam from terminal I found that the Steam Game Overlay was causing the crashing. Just right click the game in Steam go to “Properties” and uncheck “Enable the Steam Overlay while in-game”

Two other issues

  1. My mouse wasn’t working on the menus/game interface
  • Solution: Edit ~/.config/Epic/PortalWars/Saved/Config/LinuxNoEditor/GameUserSettings.ini
  • Change “FullscreenMode=0” to “FullscreenMode=1”
  1. I have multiple monitors and my mouse kept moving to my second monitor even in fullscreen mode. No quick solution for this. Probably won’t trouble it either as I’m not super interested in this particular game. And I’m not the only one with this one either looks like.

Gday Kden
Thanks for that , awesome effort

Splitgate seems to be one of the small games that uses UE4 + Vulkan that’s actually Native on Linux,
besides that the rehash of Descent which I got via early access and which was pulled ,
worked in VULKAN and UE4 on Linux also

Is the step by step info to swap between the different AMD settings on a forum post/wiki/guide/video ?
I’m definally not an expert of the CLI commandry yet in Linux

I also turn off the steam overly in most games as it pops up crap while playing and recording

I also came across the issue that it changed from Screen 01 to Screen 02

I managed to duel boot into Ubuntu Mate LTS
Splitgate worked out of the box , and the Ascent worked
yet Insurgency failed to work

It seems handy having a backup Linux installed
yet apt install system seems to be missing a LOT compared to pacman -S
espically a lot of the command line tools ive come across which are handy

appimage files work both on EndOS and Ubuntu Mate LTS

Few of us in Australia and NZ will be doing a ATS Christmas present delivery stream later tonight
(6:45am AEST GMT+10 Brisbane/QLD/AUstralia currently )

So hopefully American Truck Sim works well under Linux and Arch

Free Demo available at :-

Also side note :-

EndOS Live and Ubuntu Mate LTS live USB mode works with viewing censortube, odysee and bitchute
on Live Firefox , yet Fedora Live doesnt work with any video site

Good work EndOS team for getting a functional browser in LIVE mode ,
Which comes in handy for tutorials and such when your researching things for linux

One thing thou most Distro Live modes lack a USB image burner tool
to burn extra usb sticks to boot from , either

Thank you for everyone looking into this, replying and offering help

Best of luck, Season Greetings
Travel safe, avoid the idiots on the roads during public holidays
Eat well, be sure to drink plenty of water :slight_smile:


29/Dec/2021 - So I still cant play 7D2D or Splitgate

I need the information to swap between the various ‘free’ opensource drivers

Has anyone got a proper laid out guide, forum post or detailed info on this ?

So disabling the Steam Game Overlay didn’t work for Splitgate? Do you use any other HUDs? like Mangohud? Try disabling those too.
As far as switching between amdvlk and radv… I’ve explained it in a couple posts. But I guess I must not have explained it well enough. Maybe try this Reddit post will explain better for you?

Got Split gate (Vulkan) in Endvour OS (arch) using this command :-

yay -S vulkan-amdgpu-pro lib32-vulkan-amdgpu-pro

(for AMDVLK Closed Source)
via the recommended refered forum thread

Thanks for the help

Finally managed ditched Ubuntu Mate and Fedora with EndOS being my main OS now

1 Like