Gaming Performance Issue (Wine,, WoW)

I tried googling this topic but didn’t see anything related to my issue so I figured I’d give it a shot here. I use Bottles to run wine with and WoW Classic. It runs perfectly 165+ fps on Pop OS and Manjaro but it really struggles with EndeavorOS to the tune of 130fps sitting idle in non-populated areas.

I have a 2019 Helios 300 laptop which is an intel processor and an nVidia 1660 Ti GPU. I confirmed that the proprietary drivers are working and followed the exact same steps and configs as what I setup on Manjaro and Pop. It’s really just a matter of loading up the installer in Bottles and go. I even tried Lutris and got the same performance. Additionally I have run all 3 kernels (current, lts, zen) and get the same results.

I really like EOS so I would love to figure this out and curious if someone could point me in the right direction or if someone has run into this before? I’m not sure if it applies to all games since that’s the only one I play when I get the chance.

Sounds CPU related, have you tried switching to Intel Pstate driver which should be default on Ubuntu based distros and might be on Manjaro. Arch I thin uses acpi on default for most all CPUs.

I’d switch to Intel Pstate with Performance mode set to see if that help. WoW is far more CPU than GPU bound.

Yea that is true that it’s more CPU intensive. There was another post on this forum to check if Pstate is running via:


So it appears Intel Pstate is running. It is a laptop and perhaps it’s running in a limited state? What is a good tool to control that? I know in other more full distributions I am able to control that in their GUI. It doesn’t have to be a GUI tool though.

Edit: So after installing cpupower and cpupower-gui I was able to set it to performance instead of power saver. I’m now getting 165+ fps. Now I just need to figure out how to save the settings so they apply on reboot but I can figure that out.

Thank you for the help @Echoa!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.