GameScope Window Issue on Wayland

Hi all,

I’m experiencing an issue with GameScope when launching Steam games. The problem manifests as follows:

  1. Inconsistent Window Placement: The GameScope window appears at the monitor where my cursor was last clicked, rather than consistently on my primary monitor.
  2. Unreachable Window: Occasionally, when starting a Steam game a Wayland window icon appears in the taskbar, but the window itself is unreachable and fails to open. Restarting the PC is the only workaround to make games start again properly.

I’m using the following launch options in Steam:

gamemoderun gamescope -W 2560 -H 1440 -r 170 -f -e --display-index=0 --force-grab-cursor -- %command%

Does anyone have some advice or solution to resolve the issues mentioned above? Any insight or suggestion would be greatly appreciated.

System Information:

  • Operating System: EndeavourOS
  • KDE Plasma Version: 6.0.5
  • KDE Frameworks Version: 6.2.0
  • Qt Version: 6.7.1
  • Kernel Version: 6.9.1-zen1-2-zen (64-bit)
  • Graphics Platform: Wayland
  • Processors: 16 × AMD Ryzen 7 7800X3D 8-Core Processor
  • Memory: 30,5 GiB of RAM
  • Graphics Processor: AMD Radeon RX 7900 XT
  • Manufacturer: Gigabyte Technology Co., Ltd.
  • Product Name: B650 AORUS ELITE AX

Thanks in advance!

Already did this? https://wiki.archlinux.org/title/Gamescope#Wayland_support

Initially it gave me a black screen. After closing the game and reopening it, the window doesn’t even show up anymore (although I can see the a Wayland icon in the taskbar).
After removing the option, the window still wouldn’t show up. I noticed Steam was showing a Disk Write Error in the downloads whenever I tried to launch the game. Not sure if it is related to my GameScope/Wayland problem. I had to reboot my computer in order for the game to not show that error.
I tried the same things on a different game and I didn’t get a Disk Write Error, only a black screen and after removing the --expose-wayland flag, the game launched properly.