Games won't run in Steam Runtime

Moved to Endeavour from Manjaro and it has been nothing but a breath of fresh air. Everything is running and good to go. Except Steam. I installed this steam package yesterday and I tested a Proton-required game, and it worked. Today, I launched the game through Steam. No luck. I then used Lutris and wine to run the game. It worked. Same thing with Portal. Didn’t launch in steam itself, but worked just fine from terminal. What could be the problem?

I have a Nvidia GPU, and my OS is up to date. If there’s anything else which needs to be noted to help, let me know.

1 Like
  1. Welcome! :partying_face:

  2. Although it’s clearly not the issue, but still make sure you meet all the requirements

  3. In SteamViewSettingsSteam Play
    Make sure that:
    :ballot_box_with_check: Enable steam Play for supported titles
    :ballot_box_with_check: Enable steam Play for all other titles
    Run other titles with dropdown should NOT be set to Experimental, but instead it should be set to latest version of usual Proton.

1 Like

If you run steam from the terminal you’ll get some feedback that’ll help diagnose your issues.


For 1, I suppose I should have mentioned I have a 1660. And 2, Everything in Steam Play is enabled with the latest version of Proton.

1 Like

Thank you for that; I ran Steam through the terminal, and attempted to launch Enter the Gungeon with it. This is the feedback I got from it.

1 Like


Try to launch steam from terminal and then:
SteamCheck for Steam client updates…

Looks like it’s outdated for some reason, try and report any errors from terminal

Steam says its up-to-date.

1 Like

Ok, I’ve found a temporary solution. For ETG at least, I created a file called steam_appid.txt and put its appID in there. and if I were to launch it directly, it worked. So for now I’ll just run wine-required games via Lutris and native linux games from their directory.

Also tested the method for ETG with Getting Over It and that too worked.
I used this thread on Klei’s forum to help solve my problem.

Thank you though @keybreak and @dodgypast for your help.

EDIT: The solution on the Klei forum is found at the very bottom.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.