Games crash to desktop after a minute

When playing a game, like Fallout 4 for example, it crashes and closes to the desktop environment. The only games it doesn’t seem to do this on is indie sandbox games like Lawn Mowing Simulator.

Sometimes it’s during something specific, like in Fallout 4, when being lowered into the vault at the beginning, it crashes then in the same manner every single time.

I originally noticed that it was doing it in Riders Republic and thought it was something to do with that game specifically.

I tried launching Steam in console, that doesn’t reveal anything helpful. I tried X11, still crashes.

Ugh, I really don’t want to go back to Windows but I might have to.

Rider’s Republic: https://www.protondb.com/app/2290180
Fallout 4: https://www.protondb.com/app/377160

Try out some of the fixes/workarounds. If none work, then all the best in your EndeavourOS!
:enos_flag: :vulcan_salute:

Interestingly Fallout 4 doesn’t crash after I put “vm.max_map_count=2147483642” in a conf file in /etc/sysctl.d and switched Ambient Occlusion to HBAO+ (Ultra) in its settings applet. If neither of those are set it will start crashing again.

Maybe that will give me something to try for Riders Republic as well.

The power of troubleshooting.
:saluting_face:

PS: In most cases, it is not the OS, but instead it is the settings or the user. In this case, it was just the settings. :wink:

1 Like

It randomly started crashing again. Now it crashes whenever I open the perks menu (after buying a couple of perks) and sometimes just randomly. I’m all out of suggestions. Gaming on Linux just isn’t working for me.

There are other things you can try, actually. Different kernels, different game clients, etc. Have a look here:


Updated my BIOS (saw some forum discussion that someone mentioned that older motherboards with newer cards can be problematic if their BIOS isn’t updated, which I never update mine usually), that didn’t do the trick.

I did succeed in isolating it to DXVK specifically. Since I was able to play for at least half an hour just now, albeit a laggy experience, can say that it works with PROTON_USE_WINED3D11=1 in the launch option, which reverts to DXOGL instead.

Horizon zero dawn will only play in windowed mode for me. It took me some time to figure it out. Even on low graphic settings a full screen game will play for about 20 sec and then freeze.