Games aren't working on new build

Just built a new PC and installed Endeavour on it. I followed the gaming guide to get everything set up but I’m having some issues. Performance is terrible in CS2, I keep getting huge lags spikes randomly that make the game unplayable. It will freeze up for 6-10 second at a time at random intervals. I also tried Counter Strike source which is a game I’ve never had any issues running on linux and it won’t even launch, either natively or with proton. Both these games have native support so I have no idea what the issue is.

System specs are as follows:

Computer Information:
Manufacturer: ASRock
Model: B550 Pro4
Form Factor: Desktop
No Touch Input Detected
Processor Information:
CPU Vendor: AuthenticAMD
CPU Brand: AMD Ryzen 7 5800X 8-Core Processor
CPU Family: 0x19
CPU Model: 0x21
CPU Stepping: 0x2
CPU Type: 0x0
Speed: 4850 MHz
16 logical processors
8 physical processors
Hyper-threading: Supported
FCMOV: Supported
SSE2: Supported
SSE3: Supported
SSSE3: Supported
SSE4a: Supported
SSE41: Supported
SSE42: Supported
AES: Supported
AVX: Supported
AVX2: Supported
AVX512F: Unsupported
AVX512PF: Unsupported
AVX512ER: Unsupported
AVX512CD: Unsupported
AVX512VNNI: Unsupported
SHA: Supported
CMPXCHG16B: Supported
LAHF/SAHF: Supported
PrefetchW: Unsupported
Operating System Version:
"EndeavourOS Linux" (64 bit)
Kernel Name: Linux
Kernel Version: 6.6.2-arch1-1
X Server Vendor: The X.Org Foundation
X Server Release: 12101009
X Window Manager: KWin
Steam Runtime Version: steam-runtime_0.20231024.64411
Video Card:
Driver: AMD AMD Radeon RX 7800 XT (gfx1101, LLVM 16.0.6, DRM 3.54, 6.6.2-arch1-1)
Driver Version: 4.6 (Compatibility Profile) Mesa 23.2.1-arch1.2
OpenGL Version: 4.6
Desktop Color Depth: 24 bits per pixel
Monitor Refresh Rate: 119 Hz
VendorID: 0x1002
DeviceID: 0x747e
Revision Not Detected
Number of Monitors: 1
Number of Logical Video Cards: 1
Primary Display Resolution: 1920 x 1080
Desktop Resolution: 1920 x 1080
Primary Display Size: 20.91" x 11.77" (23.98" diag), 53.1cm x 29.9cm (60.9cm diag)
Primary VRAM: 16384 MB
Sound card:
Audio device: USB Mixer
RAM: 15914 Mb
VR Hardware:
VR Headset: None detected
UI Language: English
Total Hard Disk Space Available: 1875696 MB
Largest Free Hard Disk Block: 1716162 MB
Number of SSDs: 4
SSD sizes: 2000G,2000G,1024G,0B
Number of HDDs: 0
Number of removable drives: 0

If there is any more info that would be helpful in diagnosing this let me know and I will provide it.

if you installed amdvlk/lib32-amdvlk, remove it and install vulkan-radeon/lib32-vulkan-radeon

Also, try installing steam-native-runtime and try playing with that - steam uses the system libraries then and not the included ones from the steam-runtime.


^ That

Also I wouldn’t recommend “Native” games anyway. Just use Proton if you can. (in my experience playing native linux version of the game could produces… unforeseen consequences).

And try to add this:

DRI_PRIME=1 DXVK_FILTER_DEVICE_NAME="your GPU name" gamemoderun %command%

Maybe it could help.


can you report

inxi -Fza
1 Like

Vac secure games won’t let you play on Official servers (or even vac secure servers) with proton. For both CS2 and Source we have to use native sadly.

Another note to add is to try and launch with -vulkan

I already had those packages installed, but I gave the native runtime a shot. I was able to launch CS:S but it wouldn’t refresh the server list, it said that Steam Beta must be running to find servers.

  Kernel: 6.6.2-arch1-1 arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc available: hpet,acpi_pm
    parameters: BOOT_IMAGE=/boot/vmlinuz-linux
    root=UUID=66b5ede5-9529-46a6-b183-01bec27051e8 rw nowatchdog
    nvme_load=YES loglevel=3
  Desktop: KDE Plasma v: 5.27.9 tk: Qt v: 5.15.11 wm: kwin_x11 vt: 2
    dm: SDDM Distro: EndeavourOS base: Arch Linux
  Type: Desktop Mobo: ASRock model: B550 Pro4 serial: <superuser required>
    UEFI: American Megatrends LLC. v: P2.40 date: 10/19/2022
  Info: model: AMD Ryzen 7 5800X bits: 64 type: MT MCP arch: Zen 3+ gen: 4
    level: v3 note: check built: 2022 process: TSMC n6 (7nm) family: 0x19 (25)
    model-id: 0x21 (33) stepping: 2 microcode: 0xA20120A
  Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
    L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 4 MiB desc: 8x512 KiB
    L3: 32 MiB desc: 1x32 MiB
  Speed (MHz): avg: 3525 high: 4493 min/max: 2200/4850 boost: enabled
    scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 2200 2: 3106
    3: 3336 4: 3617 5: 4493 6: 2899 7: 3814 8: 3929 9: 3834 10: 3357 11: 2959
    12: 3648 13: 4446 14: 3439 15: 3666 16: 3660 bogomips: 121429
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Type: gather_data_sampling status: Not affected
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed status: Not affected
  Type: spec_rstack_overflow status: Vulnerable: Safe RET, no microcode
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: always-on, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: AMD Navi 32 [Radeon RX 7700 XT / 7800 XT] vendor: Sapphire
    driver: amdgpu v: kernel arch: RDNA-3 code: Navi-3x process: TSMC n5 (5nm)
    built: 2022+ pcie: gen: 4 speed: 16 GT/s lanes: 16 ports: active: DP-1
    empty: DP-2,HDMI-A-1,HDMI-A-2 bus-ID: 08:00.0 chip-ID: 1002:747e
    class-ID: 0300
  Display: x11 server: X.Org v: 21.1.9 compositor: kwin_x11 driver: X:
    loaded: amdgpu unloaded: modesetting,radeon alternate: fbdev,vesa
    dri: radeonsi gpu: amdgpu display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
    s-diag: 582mm (22.93")
  Monitor-1: DP-1 mapped: DisplayPort-0 model: ViewSonic XG2401 SERIES
    serial: <filter> built: 2018 res: 1920x1080 dpi: 92 gamma: 1.2
    size: 531x299mm (20.91x11.77") diag: 609mm (24") ratio: 16:9 modes:
    max: 1920x1080 min: 720x400
  API: EGL v: 1.5 hw: drv: amd radeonsi platforms: device: 0 drv: radeonsi
    device: 1 drv: swrast surfaceless: drv: radeonsi x11: drv: radeonsi
    inactive: gbm,wayland
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: amd mesa v: 23.2.1-arch1.2
    glx-v: 1.4 direct-render: yes renderer: AMD Radeon RX 7800 XT (gfx1101 LLVM
    16.0.6 DRM 3.54 6.6.2-arch1-1) device-ID: 1002:747e memory: 15.62 GiB
    unified: no
  API: Vulkan v: 1.3.269 layers: 4 device: 0 type: discrete-gpu name: AMD
    Radeon RX 7800 XT (RADV GFX1101) driver: mesa radv v: 23.2.1-arch1.2
    device-ID: 1002:747e surfaces: xcb,xlib
  Device-1: AMD Navi 31 HDMI/DP Audio driver: snd_hda_intel v: kernel pcie:
    gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 08:00.1 chip-ID: 1002:ab30
    class-ID: 0403
  Device-2: AMD Starship/Matisse HD Audio vendor: ASRock
    driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
    bus-ID: 0a:00.4 chip-ID: 1022:1487 class-ID: 0403
  Device-3: Kingston HyperX 7.1 Audio
    driver: hid-generic,snd-usb-audio,usbhid type: USB rev: 2.0 speed: 12 Mb/s
    lanes: 1 mode: 1.1 bus-ID: 3-4:3 chip-ID: 0951:16a4 class-ID: 0300
    serial: <filter>
  API: ALSA v: k6.6.2-arch1-1 status: kernel-api
    tools: alsactl,alsamixer,amixer
  Server-1: PipeWire v: 1.0.0 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: ASRock driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1
    port: f000 bus-ID: 04:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp4s0 state: down mac: <filter>
  Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel pcie: gen: 2
    speed: 5 GT/s lanes: 1 bus-ID: 05:00.0 chip-ID: 8086:2723 class-ID: 0280
  IF: wlan0 state: up mac: <filter>
  Device-1: Intel AX200 Bluetooth driver: btusb v: 0.8 type: USB rev: 2.0
    speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-9:5 chip-ID: 8087:0029
    class-ID: e001
  Report: btmgmt ID: hci0 rfk-id: 2 state: down bt-service: disabled
    rfk-block: hardware: no software: no address: N/A
  Local Storage: total: 4.57 TiB used: 65.33 GiB (1.4%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: SSD 990 PRO 2TB
    size: 1.82 TiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s
    lanes: 4 tech: SSD serial: <filter> fw-rev: 0B2QJXG7 temp: 28.9 C
    scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: TeamGroup model: T-FORCE 1TB
    size: 953.87 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    tech: SSD serial: <filter> fw-rev: LB.5 scheme: MBR
  ID-3: /dev/sdb maj-min: 8:16 vendor: Seagate model: ST2000DM006-2DM164
    size: 1.82 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    tech: HDD rpm: 7200 serial: <filter> fw-rev: CC26 scheme: GPT
  ID-1: / raw-size: 1.82 TiB size: 1.79 TiB (98.37%) used: 65.33 GiB (3.6%)
    fs: ext4 dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-2: /boot/efi raw-size: 1000 MiB size: 998 MiB (99.80%)
    used: 288 KiB (0.0%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  Alert: No swap data was found.
  System Temperatures: cpu: 48.6 C mobo: N/A gpu: amdgpu temp: 33.0 C
    mem: 47.0 C
  Fan Speeds (rpm): N/A gpu: amdgpu fan: 4
  Processes: 403 Uptime: 8m wakeups: 0 Memory: total: 16 GiB
  available: 15.54 GiB used: 4.05 GiB (26.1%) Init: systemd v: 254
  default: graphical tool: systemctl Compilers: gcc: 13.2.1 Packages:
  pm: pacman pkgs: 1141 libs: 407 tools: yay Shell: Bash v: 5.2.21
  running-in: konsole inxi: 3.3.31

You have to remove amdvlk - as long as it is installed, games use that and it is bad (compared to vulkan-radeon)

Also, try to play the game for 10-15 minutes as some disk caches need to be generated first, afterwards performance should be great.

that is really bad advice. In addition to the already mentioned cheating protection, that also tells developers that windoze versions are enough and that they can stop provide native builds. And performance of native builds is always better than protonified versions (at least on my 7700X RX6750XT machine, haven’t used anything else for over a year)

Edit: Kernel 6.6.3 contains many AMD GPU fixes and is in stable already, also, mesa 23.3.0 got released yesterday evening but is not in testing yet - both could also help as your GPU is rather new.

Thanks, CS2 runs snoothly after removing that package. CS:S does too, the issue was to do with the game itself, and I solved it by using some launch options I found on Protondb.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.